Toradex SDK 2.3 not Installable with VS2013

I can’t install the Windows Embedded Compact 2013 SDK version 2.3 on a freshly installed Windows 10*, when I start the setup I get: “You must install Windows Embedded XAML Tools before you can proceed with this SDK installation”. Version 2.0 and 2.2 are installable.


  • Windows 10 with all Updates
  • AppBuilderSetup VS2013 V60801

When I compare the setup with a MSI tool I see that version 2.0 and 2.2 ‘missing’ the the call for “CheckPreReqWEXTInstalled” and release note for 2.0 states: “Modified MSI to prevent issues with missing XAML Tools when installing SDK.”.

Is it possible to remove this check from version 2.3?

I’ve tested it with Visual Studio 2013 Community Edition with all packages installed (including the “Blend for Visual Studio”.
Also I’ve tested it with Visual Studio 2015 Pro with the following features selected: Common Tools for Visual C++ 15, Microsoft Foundation Classes for C++

Same result.

Searched a little bit and it looks like the AppBuilder from MS installs the XAML Tools only with VS 2013/2013 Pro/Enterprise.

Dear @TriUrs

We’re using VS2015 Professional here, so I don’t have the same setup here as you do.
But I’m pretty sure I also read about the limitation that the Community Edition is not sufficient to develop applications for Embedded Boards.

Regards, Andy

I also tested it with the VS2105 Pro version & latest AppBuilderSetup VS2015 with the same error. Do I need to install a feature in VS2015? I haven’t installed everything.
Do you have Toradex SDK 2.3 installed?
Probably you can attach a screenshot of the installed featuers in VS2015?

Dear @TriUrs
I tested the installation on a different machine and actually found a problem - the check for the XAML tools fails even if the XAML tools are installed.
I uploaded a new version of SDK 2.3 installer with that check removed.

Best Regards

Works! Thank you!