Toradex Easy Installer Error on Colibri iMX6

I just successfully used the easy installer on a Colibri iMX6S, but I just tried it again on the iMX6DL and I got stuck right after starting the kernel for the easy installer. I put the device into recovery mode using the bmode usb command then ran the recovery script and ran into these errors:

Starting kernel ...

[    0.417866] fec 2188000.ethernet (unnamed net_device) (uninitialized): Invalid MAC address: 00:000
[    0.435831] imx_usb 2184000.usb: Can't register ci_hdrc platform device, err=-517
[    0.723183] snvs-secvio 20cc000.caam-snvs: can't get snvs clock
Running /etc/rc.local...
/ # [    2.348738] sd 0:0:0:0: [sda] No Caching mode page found
[    2.354210] sd 0:0:0:0: [sda] Assuming drive cache: write through
[    3.093672] blk_update_request: I/O error, dev sda, sector 16256
[    3.193653] blk_update_request: I/O error, dev sda, sector 16256
[    3.199699] Buffer I/O error on dev sda, logical block 2032, async page read

Added Details--------------------------------------------------------------------------
My issues are with the Colibri iMX6DL 512MB with a eDM-CB-Colibri Baseboard developed by DATA MODUL (version August 2015)

The software version is:
Angstrom v2014.12 - Kernel 3.10.17

There was no usb or sd card inserted and the only things connected to the device are an ethernet, micro usb to host computer, and serial cable to host computer.

When it boots (successfully) into the older image off the eMMC, I noticed it keeps giving a similar error repeatedly before it finishes booting:

[   13.438510] Read(10): 28 00 00 00 10 00 00 00 08 00
[   13.542023] sd 0:0:0:0: [sda] Unhandled error code
[   13.546864] sd 0:0:0:0: [sda]  
[   13.550026] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[   13.555651] sd 0:0:0:0: [sda] CDB:

The only usb stick that I have been using with the device shows up as “sdb” not “sda”. I ran the usb commands and the only removable storage device is the easyTOUCH (touchscreen driver?) that came with this device. DATA MODUL is the company we bought our entire device from.

Colibri iMX6 # usb start
starting USB...
USB0:   Port not available.
USB1:   USB EHCI 1.00
scanning bus 1 for devices... 3 USB Device(s) found
       scanning usb for storage devices... 1 Storage Device(s) found
       scanning usb for ethernet devices... 0 Ethernet Device(s) found
Colibri iMX6 # usb tree
USB device tree:
  1  Hub (480 Mb/s, 0mA)
  |  u-boot EHCI Host Controller 
  +-2  Hub (480 Mb/s, 2mA)
    +-3  Mass Storage (12 Mb/s, 100mA)
         DATA MODUL easyTOUCH 5Y061
Colibri iMX6 # usb storage
  Device 0: Vendor: DM       Rev: 1.00 Prod: easyTOUCH       
            Type: Removable Hard Disk
            Capacity: 8.0 MB = 0.0 GB (16384 x 512)
Colibri iMX6 # usb part sda

Partition Map for USB device 0  --   Partition Type: DOS

The errors with sda point towards a USB memory stick being connected, correct? Could you try this without that one connected? If that does not resolve the issue please reveal the exact hardware/software versions of things you are talking about as well as on what carrier board and how that one is hooked up to its environment.

@YogurtCrampz The sda device in this case is the touchEASY touch controller of the Data Modul Panel PC which has a mass storage mode used for configuring the controller. I don’t believe the error is a problem for Toradex Easy Installer. I just tested it and am still able to flash images using Toradex Easy Installer despite the error.

The user interface for the easy installer still isn’t booting after I run the recovery script. Is it possible there are some environment variables that need to be set in uboot? After the errors that I gave in the first block of code, it enters the sh shell without displaying any user interface.

The user interface for the easy installer still isn’t booting after I run the recovery script. Is it possible there are some environment variables that need to be set in uboot?

No, the U-Boot as used by the Toradex Easy Installer does always use its default environment in order to be robust against custom environment that may still live in flash.

After the errors that I gave in the first block of code, it enters the sh shell without displaying any user interface.

What display are you using? Maybe there is just an issue with initialising that one.

I am working with the 10.1” ARM Panel PC PCAP Touch by DATA MODUL

Display: EP 101WARM131-PCAP-DM
Projective capacitive with 3mm cover glass

Resolution: 1280x800

That sounds correct. Now that I think about it, if I remember correctly, the display wasn’t showing anything when I first flashed a newer Toradex image to this 10.1" device using an SD card. I had to change vidargs to 1280x800 from the default which is 600x480 or something. Because you said it reinitializes all the variables when you put it in recovery mode, is there a way I can manually change the resolution in vidargs to see if that works?

Currently the Toradex Easy Installer uses fixed 640x480…

You can use RNDIS (network over USB) and a VNC viewer. The module should assign the host a IP address, and you can connect to the module by pointing VNC viewer to (see also Usage part of the Toradex Easy Installer Article).

I was able to display the device’s screen on my host computer by following this, but that only works after it boots the Toradex image. Now, I am confused as to how I can set it up to where I can display the device’s screen after booting the easy installer. For this method, I have to use the x11vnc -display :0 command on the device, but am not able to run it in the shell after the easy installer has launched.

After booting the easy installer, I tried running gvncviewer on my host computer, (without running x11vnc -display :0 on the target) and it looks like it connected for a split second:

Connected to server
Remote desktop size changed to 640x480
Connection initialized
Disconnected from server

After that, it just fails to connect to the server

…turns out plugging it into a monitor works.

Since you guys were able to narrow it down to a display issue, I tried plugging the device into a monitor, thinking “hey why not?”…aaaaand it works. Thank you guys for all the help!

You do not have to start the VNC server manually, the Toradex Easy Installer VNC server is built in. Just connect to it using a VNC client.

Hm, not sure why it did not work with gvncviewer, it works here with gvncviewer 0.7.1, what version are you using? I also successfully tested the Gnome built-in Remote Desktop Viewer or TightVNC Viewer from Windows.

It says im using version 0.5.3-1.3ubuntu2.1 and I tried upgrading it but it says that’s the newest version.

Just in case I’m missing something, was there anything else I need to install or set up on either the host or target, or is gvncviewer supposed to work with any of the devices when connected via usb?