TK1 is suddenly turning off


I am using Apalis tk1 module 1.1A with ixora carrier board V1.2A.
I have built multimedia image for tk1, to support my code for video streaming using gstreamer1.0-launch-1.0.
when I run my App, I use “top” command to monitor the cpu performance, it goes very high ( almost 130% for my main app)

cpufreq-info shows that the 4 cores are fully running by max frequency.
the fan is working fine. I am turning it on, so I don’t think it is a heat issue

what is the problem?
why it turns off after running my code?


Hi @rama.aloufee ,

Thank you for using the Toradex community.

Could you please try to run your application on one of the reference images, so that we can exclude a possible issue in the image itself?

You can find these images in the Toradex Easy Installer selection.

If you have further questions, feel free to ask.

Best Regards

Hi Kevin,

my app is using h264.decoder, where i need to install gstreamer1.0-libav. But it did not supported by multimedia image from easy installer.
I have checked the list from “opkg list”, gstreamer1.0-libav is not listed

also i have tried to create an application that consume 100% of the CPU, using easy installer multimedia image, but it did not turned off, it went for suspend status and did not get back to wake-up.

so you either help me in:

1- Install gstreamer1.0-libav to you image to test my app.
2- Tell me how to avoid Entering suspend mode for TK1which is running multimedia image.
3- how to enable HDMI to rework without rebooting. since HDMI is not working if TK1 went for suspend mode.
PS: I have added " idle-time=0" to weston.ini file but nothing changed

hi Kevin,

I have edited my code, it had while(1) loop, which caused the 130% usage of the cpu.
so now it is solved with 83% of the cpu usage.

1- I have installed libav and their dependencies packages from the ipk that i built for multimedia image uding my usb
opkg install /media/sda1/armv7at2hf-neon/gstreamer1.0-libav /media/sda1/armv7at2hf-neon/libavcodec58_4.2.2-r0_armv7at2hf-neon.ipk /media/sda1/armv7at2hf-neon/libavfilter7_4.2.2-r0_armv7at2hf-neon.ipk /media/sda1/armv7at2hf-neon/libavformat58_4.2.2-r0_armv7at2hf-neon.ipk /media/sda1/armv7at2hf-neon/libavutil56_4.2.2-r0_armv7at2hf-neon.ipk /media/sda1/armv7at2hf-neon/libc6 /media/sda1/armv7at2hf-neon/libavresample4_4.2.2-r0_armv7at2hf-neon.ipk /media/sda1/armv7at2hf-neon/libswresample3_4.2.2-r0_armv7at2hf-neon.ipk /media/sda1/armv7at2hf-neon/libpostproc55_4.2.2-r0_armv7at2hf-neon.ipk /media/sda1/armv7at2hf-neon/libnss-db2_2.31+git0+f84949f1c4-r0_armv7at2hf-neon.ipk /media/sda1/armv7at2hf-neon/libx264-159_r2991+git0+1771b556ee-r0_armv7at2hf-neon.ipk /media/sda1/armv7at2hf-neon/linux-libc-headers-dev_5.4-r0_armv7at2hf-neon.ipk /media/sda1/armv7at2hf-neon/libswscale5_4.2.2-r0_armv7at2hf-neon.ipk**

2- to avoid entering suspend mode you have to add " idle-time=0" under core category to /etc/xdg/weston/weston.ini file
note: i missed writing it, wrongly i typed ilde not idle for sorry. but now it works fine
echo 100000 > /sys/power/pm_freeze_timeout

Hi @rama.aloufee ,

Sorry for the delay.

So the issue is now solved?

Best Regards

yes all is fine thank you