The TEZI GUI disappears when using SD with 3 partitions.(Close)

I met a bug where the TEZI GUI was not displayed.

The TEZI GUI will appear for a moment, but it will end immediately and the Toradex logo will be displayed.

However, it seems that writing is being done.

The procedure for causing a problem is as follows.

Use an SD with 3 partitions.

All partition formats are ext4.

The first partition contains the TEZI and OS images for flashing the ROM.

Also, the OS image setting is “autoinstall = true”.

This bug does not occur with “auto install = false”.

Other partitions have user data, but it doesn’t seem to matter if the file exists or not.

TEZI is started from U-Boot with ”run distro_bootcmd".

However, booting TEZI from ROM has the same result.

Even if there are two partitions, the problem will occur.

I attached log.(/var/volatile/tezi.log)

link text

Best regards.

Sorry for the delay. I’ve been trying to reproduce this issue but I couldn’t. So far I’ve used TEZI 2.0b7 (just released). Can you try there and see if the issue is reproduced in the latest TEZI?

For a quick fix, I can only recommend using a single partition if possible.

I can’t try it now because the LCD cable is broken.
Can you try with 2.0b6?
All partitions must be formatted with ext4. Reproduction is easy.

Best regards.

This issue did not occur with TEZI 2.0b7.
This hasn’t been fixed in the roadmap, has it been fixed?

Best regards.

We updated the kernel version to 5.x between 2.0b7 and 2.0b6. Maybe it was fixed with the update.

This issue occurs with slow boot USB sticks and SD cards with multiple partitions.

I expect this issue to be a timing issue.

The problem may not have been resolved just because the new kernel was out of timing.

Therefore, in some cases, it may be reproduced even with 2.0b7.

Since the GUI disappears, I think it is originally a problem with the GUI application.

Could you please analyze this issue?

Reproduction is easy with 2.0b6.

Best regards.

I think I could reproduce the issue but only in 2.0b6. In my case it gets stuck at the “Erasing partition” screen but installation seems to go OK by checking the tezi.log and after a restart. Let me check, maybe we changed something else between versions.

Hi @developer0916, I could confirm with the development team that there was an issue with a lockup in the GUI in certain cases (like the one you mentioned) and this was solved about a month ago. I could confirm that this change is already implemented in Toradex Easy Installer 2.0b7-20210415, hence why this didn’t happen in that version.

I pinged the team to also publish the issue in our issue tracker.

Thanks, once again, for reporting an issue. Have a nice weekend.

Kind regards, Alvaro.

@developer0916 Can we open the question for future reference? Thanks in advance.

Here is the issue: https://developer.toradex.com/software/toradex-easy-installer/release-details?issue=773&key=TEI-773

Thank you for your confirmation.

Best regards.