The application doesn't run on WIN CE6

The application developed by VS2008 used to work on Colibri T20 but now it doesn’t run.
I debugged the code and it seems that it cannot find commctrl.dll module.
Where can I find this file ?


Which image version are you using?

On the module it is written V1.2

The version of the image is not related to the version of the module. Please check in the update tool: Start->Programs->ColibriTools->UpdateTool. In the tool you find a button “Version Info” which should show you a window with Image and Bootlaoder Version of the device. Please make sure you have image 2.0 on the device, this could be related to issue 17513 .

I checked.
they are version 0.1 Beta, Build 7
I tried to put the image 2.0 but when I select the ce6.cfg file in the update sequence I get an error that aborts it.
What should I do about it ?

Thanksalt text

@shiva_eghbal: This is a beta image version from 2012, we did not test the upgrade path from very old beta versions. In order to update to the 2.0 final image, please try to use the Recovery Mode (NVflash), which is documented here. Let me know if you need further support with this.

I have tried to use the Recovery mode but when I type:
reboot rcm, in bootloader menu, it get stuck on “rebooting” and nothing happens. Therefore I don’t have APX later in device manager. What should I do ?

If you don’t see any device popping up in the device manager, there is something wrong. After typing reboot rcm, your devic should show “Rebooting…” and you should have no other output after that. If this is the case, you should see a new device in the device manager. If not, check the following points:

  • Did you attach a USB cable ?
  • Does your carrier usb fullspeed (2.0)?

Yes I did attach the USB and I had changed the settings is registry to disable high speed USB, therefore it should be full speed.

@shiva_eghbal : The recovery mode only works with Highspeed, see also the “Important” note on the recovery mode page.

You can either flash the modul in a carrier board, that supports highspeed or patch your carrier board to support highspeed.

I managed to update the image version on the Colibri but my application still won’t run.
Do you know what causes that?

Do you still have the commctrl.dll issue? If you really have image 2.0 the dll commctrl.dll is definitively there. Do you may use some features that are not supported on Windows Embedded Compact? Do you get some additional output on the debug output?