Testing 10" DSI display on development Yocto images

I am testing the 10.1" DSI display sold by Toradex with the Verdin i.MX8M Plus SOM and Mallow board. There is a known touch issue which @bruno.tx has indicated is fixed in the next BSP release. I would like to try the touch function with the nightly/monthly Yocto image releases which have the fix already.

I tried both the nightly and monthly images but both fail to find the verdin-imx8mp_panel-cap-touch-10inch-dsi_overlay.dtbo after I modify the overlays.txt file to include that overlay. The boot log error is:

Applying Overlay: verdin-imx8mp_panel-cap-touch-10inch-dsi_overlay.dtbo
3843 bytes read in 1 ms (3.7 MiB/s)
failed on fdt_overlay_apply(): FDT_ERR_NOTFOUND

My tdx-info is below:

Software summary

Bootloader: U-Boot
Kernel version: 6.1.92-6.7.0-devel+git.88690811da69 #1 SMP PREEMPT Sat May 25 14:21:36 UTC 2024
Kernel command line: root=PARTUUID=81d64539-02 ro rootwait console=tty1 console=ttymxc2,115200 consoleblank=0 earlycon
Distro name: NAME=“TDX Wayland with XWayland Upstream”
Distro version: VERSION_ID=6.7.0-devel-202406-build.21
Distro variant: -
Hostname: verdin-imx8mp-15335618

Hardware info

HW model: Toradex Verdin iMX8M Plus on Verdin Development Board
Toradex version: 0063 V1.1B
Serial number: 15335618
Processor arch: aarch64


Hi, I’m the Toradex AI Assistant. I’m in early beta, and I would appreciate your feedback.
The Toradex Support team will follow up with you shortly!

Did you like my answer?

:+1: :-1:


The issue you’re encountering with the verdin-imx8mp_panel-cap-touch-10inch-dsi_overlay.dtbo not being found during boot, despite being specified in the overlays.txt file, suggests a possible mismatch or absence of the overlay file in the boot partition for the Yocto image you’re using.

Here are a few steps to troubleshoot and potentially resolve the issue:

  1. Verify Overlay File Presence: Ensure that the verdin-imx8mp_panel-cap-touch-10inch-dsi_overlay.dtbo file actually exists in the /boot/overlays/ directory of the boot partition. If the file is missing, the overlay cannot be applied, leading to the FDT_ERR_NOTFOUND error.

  2. Update to the Latest Yocto Image: Since you’re looking to test the touch functionality with a fix that is available in nightly/monthly releases, ensure you’re using the very latest image. It’s possible that the overlay file was added or updated in a release after the ones you’ve tried.

  3. Check Overlay Compatibility: Verify that the overlay is compatible with the BSP version you’re using. Incompatibilities between the device tree overlays and the BSP version might cause the overlay application to fail.

  4. Manual Overlay Application for Testing: As a temporary measure for testing purposes, you can try manually applying the device tree overlay from the U-Boot command line using the fdt commands. This approach requires a deeper understanding of the U-Boot environment and should be done with caution.

  5. Review U-Boot Environment Variables: Ensure that the U-Boot environment variables related to device tree overlays are correctly set. Incorrect settings here could prevent overlays from being applied properly.

  6. Kernel and U-Boot Compatibility: Ensure that both the kernel and U-Boot versions you’re using are compatible with each other and with the overlays. Sometimes, updates in one can necessitate updates in the other.

If after checking these steps the issue persists, it might be related to a more specific problem with the nightly or monthly Yocto image you’re using. Since the touch issue fix you’re interested in is known and addressed in future BSP releases, it’s also possible that the overlay’s functionality or compatibility is being refined in the images you’re testing.

Remember, when working with development or pre-release software versions, such as nightly or monthly Yocto builds, unexpected issues can arise due to the ongoing development and integration efforts.

Best regards,

Please, also check if these links can help you solve your problem:

Capacitive Touch Display 10.1" DSI | Toradex Developer Center.

I was using the mainline image initially. This problem is not present in the downstream image. This issue is closed.

1 Like