Temporary failure resolving 'deb.debian.org’

Dear Toradex Community

We are setting up an iMX8M Mini Dual Light on a Verdin carrier board.
Using a Linux host computer (Ubuntu 18.04.6 LTS) with VS Code and the Toradex Torizon Support extension (v1.4.0)
When we create a Torizon/C-C++: Create C/C++ application (Single file C++ sample) we are facing the following error:

Err:1 Index of /debian bullseye InRelease Temporary failure resolving ‘deb.debian.org

Full log

[05-08 16:21:26.547] Initializing Torizon Extension
[05-08 16:21:26.555] Checking system setup…
[05-08 16:21:26.556] Checking Moses …
[05-08 16:21:26.556] Starting backend local instance running on port 5000
[05-08 16:21:28.851] Torizon: Please wait for the end of activation process …
[05-08 16:21:34.518] Torizon Backend version 1.0.0 API version: 1.1.5
[05-08 16:21:34.518] Torizon IDE backend started
[05-08 16:21:34.518] Checking Docker …
[05-08 16:21:34.549] Docker version 20.10.17 build a89b842
[05-08 16:21:34.577] Trying connect to Toradex Verdin iMX8M Mini on Verdin Development Board(06827426)
[05-08 16:21:35.437] ARM emulation enabled.
[05-08 16:21:35.467] Torizon: no application loaded.
[05-08 16:21:35.468] Torizon Extension Initialized
[05-08 16:21:35.493] LA_OPT_NXP_Software_License v5 January 2019 EULA accepted
[05-08 16:21:47.083] Toradex Verdin iMX8M Mini on Verdin Development Board(06827426) connected
[05-08 16:21:47.083] Torizon: all devices refreshed
[05-08 16:21:59.350] No active configuration found, selecting first valid one.
[05-08 16:22:06.374] Step 1/5 : FROM torizon/debian-cross-toolchain-arm64:2-bullseye
[05-08 16:22:08.825] —> 923d116027d9
[05-08 16:22:08.826] Step 2/5 : RUN HOLD_PKGS=‘libdrm-common libdrm-amdgpu1:arm64 libdrm2:arm64’ && apt-get -y update && apt-get -y upgrade && for P in $HOLD_PKGS ; do echo ${P}=$(apt-cache show $P | sed -r -e ‘/^Version:/!d’ -e ‘s/.* //’ -e ‘/toradex/d’ -e ‘q’) ; done | xargs -r apt-get install -y --no-install-recommends && apt-mark hold $HOLD_PKGS && apt-get clean && apt-get autoremove && rm -rf /var/lib/apt/lists/*
[05-08 16:22:08.841] —> Running in 32b054c6f038
[05-08 16:23:05.431] Err:1 Index of /debian bullseye InRelease
Temporary failure resolving ‘deb.debian.org
[05-08 16:23:05.434] Err:2 Index of /debian-security bullseye-security InRelease
Temporary failure resolving ‘security.debian.org
Err:3 Index of /debian/snapshots/20210909T072507Z testing InRelease
Temporary failure resolving ‘feeds.toradex.com
[05-08 16:24:01.471] Err:4 Index of /debian bullseye-updates InRelease
Temporary failure resolving ‘deb.debian.org
[05-08 16:24:01.495] Reading package lists…
[05-08 16:24:01.518] e[91mWe[0m
[05-08 16:24:01.518] e[91m: e[0m
[05-08 16:24:01.521] e[91mFailed to fetch http://deb.debian.org/debian/dists/bullseye/InRelease Temporary failure resolving 'deb.debian.org’e[0m
[05-08 16:24:01.524] e[91m
[05-08 16:24:01.525] e[91mWe[0m
[05-08 16:24:01.528] e[91m: e[0m
[05-08 16:24:01.529] e[91mFailed to fetch http://security.debian.org/debian-security/dists/bullseye-security/InRelease Temporary failure resolving 'security.debian.org’e[0m
[05-08 16:24:01.530] e[91m
[05-08 16:24:01.531] e[91mWe[0m
[05-08 16:24:01.533] e[91m: e[0m
[05-08 16:24:01.539] e[91mFailed to fetch http://deb.debian.org/debian/dists/bullseye-updates/InRelease Temporary failure resolving 'deb.debian.org’e[0m
[05-08 16:24:01.541] e[91m
[05-08 16:24:01.542] e[91mWe[0m
[05-08 16:24:01.544] e[91m: e[0m
[05-08 16:24:01.545] e[91mFailed to fetch https://feeds.toradex.com/debian/snapshots/20210909T072507Z/dists/testing/InRelease Temporary failure resolving ‘feeds.toradex.com’e[0m
[05-08 16:24:01.549] e[91m
[05-08 16:24:01.552] e[91mWe[0m
[05-08 16:24:01.553] e[91m: e[0m
[05-08 16:24:01.554] e[91mSome index files failed to download. They have been ignored, or old ones used instead.e[0m
[05-08 16:24:01.556] e[91m
[05-08 16:24:01.557] Reading package lists…
[05-08 16:24:01.558] Building dependency tree…
[05-08 16:24:01.568] Reading state information…
[05-08 16:24:01.569] Calculating upgrade…
[05-08 16:24:01.579] 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[05-08 16:24:01.613] e[91mE: No packages found
[05-08 16:24:01.643] e[91mE: No packages found
[05-08 16:24:01.678] e[91mE: No packages found
[05-08 16:24:01.685] Reading package lists…
[05-08 16:24:01.703] Building dependency tree…
[05-08 16:24:01.721] Reading state information…
[05-08 16:24:01.722] e[91mE: Unable to locate package libdrm-common
E: Unable to locate package libdrm-amdgpu1:arm64
E: e[0m
[05-08 16:24:01.723] e[91mUnable to locate package libdrm2:arm64
[05-08 16:24:02.037] Local docker exception.
[05-08 16:24:02.038] Error (530) - Docker exception: The command ‘/bin/sh -c HOLD_PKGS=‘libdrm-common libdrm-amdgpu1:arm64 libdrm2:arm64’ && apt-get -y update && apt-get -y upgrade && for P in $HOLD_PKGS ; do echo ${P}=$(apt-cache show $P | sed -r -e ‘/^Version:/!d’ -e ‘s/.* //’ -e ‘/toradex/d’ -e ‘q’) ; done | xargs -r apt-get install -y --no-install-recommends && apt-mark hold $HOLD_PKGS && apt-get clean && apt-get autoremove && rm -rf /var/lib/apt/lists/’ returned a non-zero code: 123
message:The command '/bin/sh -c HOLD_PKGS=‘libdrm-common libdrm-amdgpu1:arm64 libdrm2:arm64’ && apt-get -y update && apt-get -y upgrade && for P in $HOLD_PKGS ; do echo ${P}=$(apt-cache show $P | sed -r -e ‘/^Version:/!d’ -e 's/.
//’ -e ‘/toradex/d’ -e ‘q’) ; done | xargs -r apt-get install -y --no-install-recommends && apt-mark hold $HOLD_PKGS && apt-get clean && apt-get autoremove && rm -rf /var/lib/apt/lists/*’ returned a non-zero code: 123
Step 1/5 : FROM torizon/debian-cross-toolchain-arm64:2-bullseye

It seems that the container is not able to reach deb.debian.org.

Any ideas how to fix this?

Are we able to run such a created container manually, to check hints
like this on stackoverflow?

Thank you in advance

Hi @Zag ,

Thanks for your message.

Would it be possible that you post here the Dockerfile as well, so that we can have a look?

Best Regards

Hi @Zag , hope you’re doing good!

In addition to what Kevin said, can you please share additional information about your setup so that we can try to reproduce it on our side?

  • Which Linux OS and version are you using? There were some additional steps that should’ve been done in Ubuntu 22.04, for instance.
  • Which commands are you running on the command line?
  • Was this project working before or it’s a newly created one?

About your other question:

Yes, you can run containers that you created externally on Torizon. You can, for instance, create your dockerfile, update it to one account in Dockerhub and link it in the application Docker-compose field. You could also connect to your board through serial or ssh and run any container with docker run. There are even a few samples on developer.toradex.com that you could run.

Best regards,

Thank you @kevin.tx and @gclaudino.tx for the quick responses.
I completed my initial post with my Ubuntu version.

It is a new setup on a newly setup computer.
I used the Torizon extension to create a demo application:

Due to the failure I don’t get a Dockerfile which I can share. The project folder does not get created at all.
By the way, my user is added to the docker group:

$ sudo addgroup <your user name> docker

@gclaudino.tx I am not sure if I understand you correctly. I meant the container which is used for building and debugging my application. Is it possible to run such a container manually on my host computer?
I have setup the same things a month ago on another device where everything worked fine.
Therefore I meant such a “dev container”.

Thank you and best regards,

Hi @Zag, thanks for the update!

This is not the expected behavior. I just tried to create a single-file C++ sample using the VSCode extension V1.4.0 and the Early Access V.1.5.209 using both arm64 architectures available without any issue. We’ll check with the development team about what could be causing it.

Therefore, can you please confirm your Ubuntu Version and the Visual Studio Code version? This way we can try to replicate your setup. Also, you’re selecting the Arm64 Wayland option, right?

Also does this error only happens when building a single C/C++ file or on other types of sample projects it also happens?

Ok, now I understand better what you meant. The dev container is an instance inside the VSCode created with one of the app extensions as you can see here: Create a development container using Visual Studio Code Remote Development. So I’d suggest you to keep it there to use our extension at the moment. By the way, I discussed with the team responsible for the extension and there are efforts about new CI/CD features for the extension and there may be other ways to interact with this kind of container in the future.

Ps: please be aware that there is a known issue with the V1.4.0 Extension that sometimes erases the reference to the Toradex Torizon Extension on the devcontainer.json file after a new project creation. Please check that it has the following fields at least:

    "extensions": [

This shall be fixed in the next stable release (V.1.5.0).

Best regards,

My used versions are as follows:

  • Ubuntu 18.04.6 LTS
  • VS Code (1.67.2)
  • Toradex Torizon Support extension (v1.4.0).

Yes, I select the Arm64 Wayland option.

It happens with any sample project.

After the errors, the directory looks like this:

├── appconfig_0
│   ├── config.yaml
│   ├── id_rsa
│   ├── id_rsa.pub
│   └── work
│       └── Dockerfile_SDK.debug
├── file.txt
└── TestApp123.cpp

2 directories, 6 files

Thank you for the explanation.
Best regards,

Dear @Zag,

Thanks for the update. Your folder structure seems fine to me.

Have you tried running the project after these files have been generated? Do you get any error on either pressing F5 or F1 - Torizon: Build Release Container for the application?

What’s the output of a F1 - Torizon: Rebuild SDK and Reload in Container?

Have you also tried to reload the window before trying again?

Best regards,

Dear @gclaudino.tx ,

This solved it for me.
First it failed again due to the fact that I specified a DNS for the Docker containers.
After I removed the DNS definition it worked when I executed: F1 - Torizon: Rebuild SDK and Reload in Container

Thank you for your help!

1 Like

Dear @Zag,

Thanks for the update! I’m glad your issue is solved. Please feel free to come back anytime needed.

Best regards,