Tegra T30ASG-Q-A3 unbricking solution?

Dear All!

I have a Fujistu FT0056A device. This device its a sat-nav in a Honda Civic.
The device is frozen. After a usb firmware flashing won’t startet. Its in boot-loop. I tryed many solutions, but not working.

The board

First time I tried to flashing from usb stick. I have thre original Honda flash file to tis device:

  • For SH USB1 - AUD31CF.bin - I can’t extract the bin file. Maybe this contain the boot and recovery images. - I can’t flash with via usb stick. Its a error message… Maybe this bin file contain the boot and the recovery images.
  • For tegra EC/NC USB2 - ADA_usbdl_VL0.FFF.04_EXT_HFT_param02.zip - Flash zip file loaded up correctly to the device via usb stick.
  • For Tegra USB3 - ADA_usbdl_V10096001123_sec_14ada.zip - Flash zip file loaded up correctly to the device via usb stick. This zip file contain a “ADA_usbdl_10.096.00.1123.enc” file. Can’t decrypt or extract. Its a password protected file. I not know whats the password…

I tried to downgrade, with older and upgrade with newer wersions, but not working…

Now I tried flashing via OTG USB on the USB-B system port
I can’t find any driver to the device. I found many driver (apx ; nvidia shield ; toradex_usbpcdriver_32_64 ; universal naked drivers ; etc.) but the ****usb.inf file not contains any record of this device, what they call it:

USB_Install, USB\VID_0955&PID_7102

USB_Install, USB\VID_0955&PID_7102&REV_0232

After the inf editing and With forced install, i can connecting the driver to the device with many “name”:
NVIDIA USB Boot-recovery driver for Mobile devices"
NVIDIA Android Fastboot Device
NVIDIA Android Composite Device
Android Debug Bridge Interface

I found thre diferent driver dll version too:







WUDFUpdate_01009.dll in another file size…

the device not aswered to the fastboot.
Fastboot devices
Cant find any device

Only the xiaomflash.exe can read a a devise serial:
but, cant flash the device…

the virtualbox can read the device informations:

link text

After adding the usb and post settings in the virtualbox, i tried flashing the board wint ubuntu.
same as with windows. The device its in the ubuntu usb device list:


but, if i like to flash the device, nothings happened. The flasher wait for the device…


how can I find a solution for flashing this board?
Its any not public device driver to this device?
How can I flash the SH AUD31.bin?

Becouse i think the Tegra files loaded up correctly via USB stick. Now i must to give a “fastboot -w” command to the device, and then can booting correctly. I tried with

“fastboot -i 0x0955 -w command too”. not working.

How can i unbrick tis device?
Any solution? :slight_smile:

Thanks for the reply
Kind REgads,


Sorry, but we can not comment on a HW platform we don’t know.


Ok, thank You…

Maybe you get luckier on the xda forum.