Task.json error on base:gcc

I have an Apalis iMX8 SOM with the Ixora board.
I am using VS Code with the Torizon early access plugin on Windows 10.

I am trying to use the following sequence of commands for a simple hello world to run in a container on the board. To being with I understand that a container is created on the development PC before sending on the board.

View → Command Palette - >Torizon:Create C/C++ application → name of application → Auto tools project → arm32v7_debian_ssh_bullseye → debug.

On the auto-generated trial.C file, I am trying to build it using Terminal → Run build task.

I am getting an error in the output as follows. This appears to be an error in the tasks.json file.
I have also tried with C-make option instead of Auto-tools, but get the same issue.
In additon there also appears to be an issue with the launch.json file as attached.

Error: the description can't be converted into a problem matcher:


    "base": "$gcc"


Error: the description can't be converted into a problem matcher:


    "base": "$gcc"


Error: the description can't be converted into a problem matcher:


    "base": "$gcc"


Greetings @SJ_BHD,

I attempted to reproduce your issue on my side and was unable to.

Just to be clear I’m running the Early Access version of the extension on Windows. I created a C/C++, Auto tools based project. Then once the project is generated, without modifying anything I run Tasks: Run Build Task.

After all that the application gets build and I can see the application binary in my project folder. So I don’t get the same error you are reporting here.

I have a couple of questions to see if we can narrow down what’s the issue on your side.

  • Is this the first time you’ve tried our VSCode extension? And if you have tried it before did you run into issues previously as well?
  • You mentioned you’re using the Early Access version of the extension is there a reason why?
  • Is this issue reproducible for you if you create a brand new project from scratch?
  • Instead of running Tasks: Run Build Task, what happens if you just hit F5 to start the entire debug cycle?

Let’s see if we can figure out what’s different about your setup that causes this issue.

Best Regards,

Hello Jeremias,

That does not work either. The F5 key is linked to Run → Start Debugging in VSCode and pressing the F5 key does nothing for me. When I click on start debugging , I get the error message as shown in the previous attachment.

Could not find the task $defaultBuildTask.

Dear @SJ_BHD,

From what I see, there is some content missing on your tasks.json file. Usually you should have in the args field something like if we talk about a single file C/C++ project:

            "args": [

Maybe if you add this kind of content there you’ll be able to solve your issue. However, we’d like to understand more about what has caused this to happen. Can you please share more details to understand what could have led to this?

  1. Which VSCode version are you using?
  2. Which exact extension version are you using?
  3. Does this happen with any new project using the same configuration set (Auto tools - arm32v7_debian…)?
  4. Does this also happen with other project types?

Best regards,

Hello Guilherme,

Thanks for your feedback on the tasks.json file. I have updated it, but I am still getting the same error when I try to debug (F5 key).

I am attaching my tasks.json file and also the launch.json file here. This will hopefully allow better diagnosis.

Regarding the queries you asked.

  1. Version of VSCode:
    Version: 1.68.0 (user setup)
    Commit: 4af164ea3a06f701fe3e89a2bcbb421d2026b68f
    Date: 2022-06-08T11:44:16.822Z
    Electron: 17.4.7
    Chromium: 98.0.4758.141
    Node.js: 16.13.0
    OS: Windows_NT x64 10.0.19042

  2. Extension version: Toradex Torizon Support (Early Access) v1.5.211

  3. I have only tried the Auto-tools and the Makefile options until now and both have the issue. Tried Arm32_debian and Arm64_Wayland.

  4. I have only tried the debug and release types and the issue is the same.

launch.json (772 Bytes)
tasks.json (3.3 KB)

Dear @SJ_BHD,

Thanks for the update. I’m sorry but I think that my message led to a misunderstanding. The lines I mentioned were to be added only to build_debug and build_release lines. Because they were the only I could see on your screenshot.

Could you please share a clean tasks.json file so that we could try to see exactly what types of content are missing? Please also tell which type of project is this tasks.json linked to.

Also, have you tried using the Stable Extension Release?

Best regards,


I have tried the stable extension as well as the Auto-tools, Makefile and Cmake options. All of these are giving the same error. It apparently is an issue with the Torizon plugin, because the plugin does ask for the name at the start and then it should auto-populate this in the launch.json and tasks.json script as per the selection.

I think I know what might be happening here. Take a look at the auto-tools project that I created to reproduce your issue:

In an auto-tools project the extension is suppose to run configure commands automatically. This produces all the extra files you see enclosed in the red box of my screenshot. Looking at your screenshot it seems for some reason these configure commands were not run.

Looking more at your screenshot I noticed that the Torizon extension is not running in the created dev container instance. Notice the yellow boxes on my screenshot that show the Torizon extension is running successfully.

What I believe is happening is that for some reason the Torizon extension is failing to start in your dev container. There’s nothing to then automatically run the configure commands. The result is you have a half finished project folder that fails to build.

Now this issue sounds similar to this known issue here: Torizon IDE Extensions Issue Tracker

But this should have been fixed by now. Could you try the workaround for this issue. The workaround is to reload the window (ctrl+shift+p->→ Reload Window). This will help tell us if it’s the same or similar issue as before.

Best Regards,

1 Like

Hi @SJ_BHD, do you have any news on this topic? Have you been able to make it work?

@gclaudino.tx - I have marked the solution above.