Tab completion doesn't work in vi-style CL editing

When I enter ‘set -o vi’ to use the vi-style line editing interface, tab completion stops working.

With the default command line interface, tab completion works correctly. When I enter ‘set -o emacs’ to use the emacs-style line editing interface, tab completion works correctly. It’s only a problem with the vi-style interface.

To reproduce the problem:

  1. Create a file called abcdefg in the current directory.
  2. Type ‘ls abc’. Tab completion works.
  3. Enter the command ‘set -o vi’, then again type ‘ls abc’. Tab completion fails.
  4. Enter the command ‘set -o emacs’, then again type ‘ls abc’. Tab completion works.

That should read “Type ‘ls abc’ followed by the TAB key.”

Hi

Please have a look here:
https://unix.stackexchange.com/questions/281849/how-to-enable-bash-completion-in-vi-mode-on-synology-dsm6

Max

This solution works on both the Apalis iMX6 and Apalis iMX8. Thx.

Perfect, that it works. Thanks for the feedback.