Svg icons are not shown in display (PySide2)

Hello Toradex team,

Our company is using the Colibri imx8 with the Colibri evaluation board to develop a new interface for our displays. I am using VSCode (Torizon Extension) and I have already designed a test GUI which I have successfully transferred to the collibri board. But I have some problems with the button icons. When I run the local Python script I can see the icons (see Localpython.png), but on the display the icons are not shown (see Displayimage.png). Also, the size of the buttons is smaller (the display resolution is set to 800x480). I tried to import PySide2.QtSvg but this lib is not recognised by the board. Do you have any idea how I can solve this problem? Can you also tell me if PySide6 will be available on Torizon soon?

The next problem I have is getting this container to start automatically every time the system is rebooted. I followed some steps I saw on your homepage but unfortunately it did not work. I had a black screen after the reboot. Is there any other way to do this, perhaps directly from the vs code?

Thank you for your help and best regards


Hello @arjanl,

Thanks for reaching out!
It looks like your local machine finds the path within which these icons are stored but the docker container in which the application is built cannot find it. You can check it on the module by stepping into the container and verify that the executable and the directory with icons are located correctly.
@matheus.tx could help you better here.

Hello @rudhi.tx,

Thank you for your message.

That was my first thought too. So I tried to change an icon to another image. As you can see at the top right corner is an image (our company logo) so this image can be displayed. I then tried to change a random icon (menu or home) to a random image that was in the same path as the company logo. I could not solve it, it happened the same thing. It worked in my local machine but not in Display. That is why I do not think that there is a problem with the path.

I have no experience at all with Torizon, can you please tell me where to find the container on the module?

Hello @arjanl,

We have updated the templates to bear support for copying files from every other directories on the workspace as the user wants. To get the updated template you could go to TASK RUNNER → try-update-template. Once you do it, you should see a COPY command at the end of Dockerfile.debug. You can just take it as a reference and write another COPY command to copy the path that you want in your workspace to the path that you want in your container.

Hello @rudhi.tx,

I cannot update templates because .template does not exist.

Get-Content: /home/alazaj/SVN/NextGenDisplay/TorizonPrototype/.conf/projectUpdater.ps1:69:17
Line |
69 | $templateName = Get-Content $projectFolder/.conf/.template
| ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| Cannot find path ‘/home/alazaj/SVN/NextGenDisplay/TorizonPrototype/.conf/.template’ because it does not exist.
The terminal process “pwsh ‘-nop’, ‘/home/alazaj/SVN/NextGenDisplay/TorizonPrototype/.conf/projectUpdater.ps1’, ‘/home/alazaj/SVN/NextGenDisplay/TorizonPrototype’, ‘TorizonPrototype’, ‘0’” terminated with exit code: 1.

I will look into this tomorrow and see if I can resolve it. I have seen some similar posts in the community.

Hello @rudhi.tx ,

I still cannot fix the above problem. I cannot update the templates. I have tried a lot of steps that I have seen in the community, but I have not had any success.

I have the latest Torizon IDE Extension installed (v2.4.0).

First I tried to create a new Torizon from scratch (also removed the path…/.apollox) and when I tried to update the templates I still had the same problem.

I then changed the settings.json as shown, reloaded the window but still had the same problem.

“apollox.templatesBranch”: “dev”,
“apollox.templatesTag”: “next”,

I then tried to manually create this .template file with the content


but it still did not work.

I have also noticed something strange in the Torizon IDE output

[01-30 11:42:40.383] ERROR :: net-tools is not installed.
[01-30 11:43:12.405] git iputils-ping nmap avahi-utils file sshpass net-tools bind9-dnsutils installation OK
[01-30 11:43:12.405] Cloning project templates
[01-30 11:43:12.418] ERROR :: Error trying to clone application templates
[01-30 11:43:12.419] Schwerwiegend: Zielpfad ‘/home/alazaj/.apollox’ existiert bereits und ist kein leeres Verzeichnis.

I don’t know why, but I keep getting these errors. I have installed net-tools, but I still get this error. Then I noticed that I could only run ifconfig with sudo, but after exporting the bin path with

PATH =$PATH:/sbin

i was able to run ifconfig without sudo but I still couldnt resolve this error.

Do you have a solution to this problem?

I was able to find a solution to this. As I suspected there was a problem with opening svg images. I made a simple gui and added png files as icons and it worked on display.

Hi arjanl,

Thanks for the update! I am just checking with the team for the reason behind the error with the task try-update-template. In the meantime, glad to hear that you could solve your issues.
About the error related to missing packages:
What is your setup like? Do you have a windows or linux development machine? In case you have WIndows, you should know that the packages are supposed to be installed in your WSL.

At first I wanted to use WSL because our company uses Windows. WSL was very stressful. I always had problems with the DNS server because the resolv.conf did not always work correctly. So I installed a virtual machine with VirtualBox and since then everything works fine. The second error disappears when I remove the .apollox file, but the first one remains (net-tools). Im using Debian 12 in VirtualBox

Hi @rudhi.tx,

have you and the team found a solution to my problem with the try-update-template task?

Best regards,

Hello @arjanl,
We were able to reproduce this issue. Our team is investigating it and I will update you as soon as I have some news there.
In the meantime, is it okay if you make this post public so that it could help someone else also running into the same issue?
Thanks for your understanding.

Hello @rudhi.tx,

Thank you very much. Yes, it is ok to make this post public.

How can I make this topic public? Or are you going to do that?

Best regards,

I just made it public.

Hello @arjanl,

Thanks for your patience. For now, as a workaround to this issue, you can create all the missing files manually until you can complete the try-update-template task successfully. Let me know how that goes.

Hello @rudhi.tx ,

i successfully updated the templates by manually adding the .template file with content tcb.

:white_check_mark: tasks.json
:white_check_mark: common
:white_check_mark: specific
:white_check_mark: Update done

After updating, I now have some other problems to deal with. I am not able to debug my program to the target.
Using the debug (F5) i get these error:

Could not find the task ‘wait-debugpy-start-arm64’

I then tried to run the tcb-deploy task but I do not really know which file I should choose here. So I randomly selected some files and I keep getting different errors as:

  • root - CRITICAL - An unexpected Exception occurred. Please provide the following stack trace to
    the Toradex TorizonCore support team:
    FileNotFoundError: [Errno 2] No such file or directory: ‘/storage/tezi/image.json’

Can you please tell me how I can debug my program to the target?

Best regards,

Hello @arjanl,

I ran into the same issue as yours:
Could not find the task ‘wait-debugpy-start-arm64’

However, I could fix it. Here is what I did:

Removed any running containers and images on the target. You can do so from VSCode by right-clicking the running containers and images and selecting the remove option.

Then I removed the connected device first by selecting the Remove Default option and then the Remove Device option. Then add the network device again, set it as default. Run and Debug again by pressing F5. In this case, it solved the issue for me and I could successfully build and deploy my Pyside application.

Hi @rudhi.tx,

Unfortunately this did not work for me. I followed all the steps as you explained but did not succeed.

I also tried removing the .apollox file, restarting my host machine and repeating the steps again but it still didnt work.


If i click here Debug Anyway, I get connect ECONNREFUSED target_ip:6512.

Best regards

Hello @arjanl,

Could you please send the output of this command from your Virtualbox:
sudo lsof -iUDP -iTCP | grep 6512

Hello @rudhi.tx,

i dont get any output if i run that command.

Best regards,