Support of rpmsg in TorizonCore on Verdin iMX8MP

Hi @vix,

Please, run these commands into the U-Boot terminal:

# setenv fdt_high 0xffffffffffffffff
# saveenv
# reset

Let me know if that fixes your issue.

With TorizonCore, the default reserved memories from NXP for RPMSG and REMOTEPROC are overlapped with our allocated regions, that’s why you are seeing this error.

The above command should disable NXP FDT relocation and boot your device.

Anyways, I’ll open a ticket internally with the TorizonCore team so we can investigate further.

Best Regards,

1 Like