Sudo password reset authentication failure

Hi am am new around here,
I have just gotten my IDE up and running and trying to learn some basic linux commands.
I installed a TorizonCore basic shell image. Also using Docker, incase that makes a difference…

So, many commands, like

$ find . -iname "myfile.txt" -type f

give me “permission denied” and so I tried:

$ sudo find . -iname "myfile.txt" -type f
`password: [used same as my user password, which I changed to torizon1 ]

but I get:
su Authentication failure

I have not changed any passwords that I am aware of,
Do I need to reinstall everything starting with the easy installer, or is there a simple fix?

Greetings @leighjboyd,

So to be clear is your password on that device torizon then? Are you sure about that?

The default password for TorizonCore should be torizon. But, for security reasons when you initially log-in to a TorizonCore device for the first time we make you change the password from this default, to anything but torizon.

Do you recall what you changed the password to on first login for that device? If not there’s no good way to retrieve your password other than reinstalling.

Best Regards,

yes, i know my password is torizon1 not torizon (typo I had written password to be “torizon!”)

Ok so with “torizon1” it does not work?

If you logout of the device and log back in does “torizon1” work as a password for login?

Exactly. Entered the same password both times.

Since I don’t even know how to change the su password, its hard to imagine that I did it by accident.

Soon I will be learning how to use TorizonCore Builder and re-install the image:


then this problem might go away, so if you want to wait until then, we can. Otherwise it would be nice to know how this could have happened. might be interesting to find out incase others have this problem. (assuming I can re-install without this password…)

Wait are you trying to use sudo or su? These are two very different commands. The su command is to switch users and requires you to know the password of the user you are switching to. By default this command switches to the “root” user which has no password, which is why you get the authentication error.

The sudo command requires the password of the user you are currently logged in as “torizon”. This is where you would use your “torizon1” password.

Best Regards,

Oh, I thought they were the same, thanks for the clarification,

So, in that case it looks like sudo works as expected

but su still gives :
no matter if I type torizon1 or CR or admin…

but if “root” user has no password, I should just type a CR then?

perhaps there is another way to find files without getting a ton of “permission denied” errors

I just tried this which seems to work

colibri-imx6-10866289:/$ find . -iname "*spi*" 2>/dev/null

But I don’t understand what it is doing, maybe it is not actually searching through those directories, but just sending the output to null…


when I type:

colibri-imx6-10866289:/$ sudo -i

it asks for a password
if i type torizon1 it lets me into root:


now when I type:
find . -iname "*spi*" 2>/dev/null

I still get a ton of garbage, but it no longer says permission denied…

Glad you were able to work things out.