Stuck at Starting Kernel ..." after loading run ubiboot

Stuck at:

U-Boot 2016.11 (Dec 07 2020 - 16:53:12 -0300)

CPU:   Freescale i.MX7D rev1.3 996 MHz (running at 792 MHz)
CPU:   Extended Commercial temperature grade (-20C to 105C) at 43C
Reset cause: POR
DRAM:  512 MiB
PMIC:  RN5T567 LSIVER=0x01 OTPVER=0x0d
NAND:  512 MiB
Video: 640x480x18
Error: no valid bmp image at 80800000
In:    serial
Out:   serial
Err:   serial
Model: Toradex Colibri iMX7 Dual 512MB V1.1D, Serial# 06413914
Net:   FEC0
Hit any key to stop autoboot:  0
Colibri iMX7 # fatload mmc 0:1 ${loadaddr} demo_m4.elf
reading demo_m4.elf
192076 bytes read in 29 ms (6.3 MiB/s)
Colibri iMX7 # bootaux ${loadaddr}
## Starting auxiliary core at 0x1FFF80BD ...
Colibri iMX7 # run ubiboot
Booting from NAND...
ubi0: default fastmap pool size: 200
ubi0: default fastmap WL pool size: 100
ubi0: attaching mtd1
ubi0: attached by fastmap
ubi0: fastmap pool size: 200
ubi0: fastmap WL pool size: 100
ubi0: attached mtd1 (name "mtd=4", size 508 MiB)
ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
ubi0: good PEBs: 4052, bad PEBs: 12, corrupted PEBs: 0
ubi0: user volume: 4, internal volumes: 1, max. volumes count: 128
ubi0: max/mean erase counter: 93/36, WL threshold: 4096, image sequence number: 855563436
ubi0: available PEBs: 0, total reserved PEBs: 4052, PEBs reserved for bad PEB handling: 68
No size specified -> Using max size (6688152)
Read 6688152 bytes from volume kernel to 81000000
No size specified -> Using max size (46706)
Read 46706 bytes from volume dtb to 82000000
Kernel image @ 0x81000000 [ 0x000000 - 0x660d98 ]
## Flattened Device Tree blob at 82000000
   Booting using the fdt blob at 0x82000000
   Loading Device Tree to 8fff1000, end 8ffff671 ... OK
   Updating MTD partitions...

Starting kernel ...

demo_m4.elf is a

void main(){}

It won’t start kernel with the provided hello_world or other elf. The firmware itself works fine, but we are not able to boot both.


bootaux {$loadaddr}

won’t work on dunfell we retrograded the U-Boot.

We are still to try to go back to 3.0.4 linux, but we baked a 5.1 custom linux already and are looking for the issue.

We tried making a new device tree after this question:

But with no success.
We are updating the device tree with
ubiupdatevol /dev/ubi0_1 imx7d-colibri-custom.dtb.

We are actually glad it is not an issue with PWM_1, since it is used by our TFT.

We can boot both with Thud. Seems like version 5.0 is not working at for applications using both A7 and M4 in parallel.

Greetings @Ilan_Figueiredo!

Can you reproduce this with our default BSP 5 image (plus U-Boot from 3.0.4)? I might have to try to reproduce this at my side and report to the BSP team.

I did and it still not worked. I used the multimedia Dunfell and updated the u-boot and dtb manually using the instructions in this article.

(the dtb from Dunfell seems to work fine on Thud Linux by the way)


Can you please try this binary? It’s the Hello World demo that comes with the SDK. I want to check if this might have something to do with the build process.