Stopping U-boot on iMX7 to change environment variables for Boot2Qt

I have tried to stop at U-Boot to change the environment variables for the 7" resistive touch display.

This did not go as planned:

  • I connected a USB RS232ttl3V3 cable
    to the pins 28,27,21 on the Iris
  • I can see the U-Boot output in Putty
    and other serial terminal programs
    but I can not stop U-Boot.
  • I am also not able to login after
    boot, as mentioned in other
  • I have tried to disable flow control
    in putty, but this did not help.
  • I can send characters if I short TX
    and RX of the serial cable.

My workaround:

  • May temporary solution was to install
    EmbeddedLinux via the
    Toradex-Easy-Installer, started via
    the recovery mode. This process with
    shorting the recovery pins on the
    colibri board is very tedious and
    requires a micro USB cable from the
    Iris board to a PC with the recovery
  • However, after installing
    EmbeddedLinux, I used a keyboard
    connected to the USB of the Iris
    board to change the environment
    variables via the fw_setenv command
    in Linux. This fixed the issue with
    the incorrect screen resolution and
    touch not working.
  • After that I installed the Boot2Qt
    image again. The u-boot environment
    variables were not deleted and the
    resistive touch screen worked fine in
    the Qt Demo image.

However, The Toradex-Easy-Installer only has the Boot2Qt 5.15.0 image and not the 5.15.1 image that I would like to use.
In order for me to install the newer boot2qt image, I want to follow the described steps:
These steps describe to stop in U-Boot, which I can not.

Also, it might be useful to stop in U-Boot in the future, which I can not do at the moment.

Also it is a very tedious process to go into recovery mode two times and to install two images, just to change an environment variable in U-Boot.

Please help. How can I stop in U-Boot?

TLDR: use the accessory kit!

Previously I have tried to connect via the RX, TX, GND pins on header X16 with a standard RS232-TTL3V3-USB adapter. This did only work to read the output of the terminal, but I was unable to write.

It seems that I have found a solution to my problem:

  • Using the RS232-USB converter from
    the Carrier-Board-Connectivity-Kit
  • using the rs232 cable from the connectivity kit
  • using the rs232 adapter from the connectivity kit
  • connecting the rs232 adapter to UART-A headers on X13
  • Creating a connection with Putty
    (115200 baud, flow control: none)

U-Boot can now be stopped immediately after pressing a button and I am able to run commands in uboot.

I will leave this here, in case anybody else has the same problem. Have a nice day.

HI @megger-ccore

Perfect that the issue is solved. Thanks for the feedback.

Best regards,