SSH connection problem

i.MX6Q rev 1.6 2Gb Freescale on IXORA board

Hi, today I’m working with a couple of old boards trying to deploy a Qt app already deployed years ago. Same error for both.
I’m not so skilled and a long time since last deploy (a couple of years) …maybe I forgot something.

The app has been developed on Qt 5.13 on Windows.
I cannot establish a SSH connection.
Qt>Device settings:
Type: Boot2Qt
Host name: (already set with ifconfig eth0 on the board)
SSH port 22
username: root

Qt>SSH settings:
Path to ssh…sftp…askpass…keygen: set and found (black font color)

Qt>Android settings:
Java and Android settings with a lot of errors but is it worth or not?

Qt Device Testing error messages:
"Connecting to host… Checking kernel versione…
uname failed.

checking ports:
Error gathering ports: Remote process crashed"

I have also tryied some command line “scp xxx yyy” with error:
“ssh: connect to host port 22: unknown error - lost connection”

No Putty end no WinSCP connection client works…

I tryied to install a new Boot2Qt image “Qt for Device Creation Demo” but same results.

Which test do I have to perform?
Thank you

Hello @agalli,

Thanks for reaching out!

If I understand you correctly, you flashed your apalis imx6 module with a Boot2Qt image and now you would like to connect to it via SSH. I tried to reproduce the issue that you are facing. Here are my steps:

  1. Installed the “Qt for Device Creation Demo” image which comes out of the box on the Toradex Easy Installer.
  2. Get the IP address of the module from ifconfig or ip a command (or you can also see it on the GUI if you have a display connected to the module)
  3. Connect using SSH using the following command: ssh root@<IP_ADDRESS>

This worked just fine for me. Could you please confirm if these are the exact same steps you followed?
Also please make sure that your module and the development PC are on the same network.

Hi Rudhi, thank you.
Point 1 & 2 ok.
Point 3 seems don’t work for me. I use a Putty or WinSCP client (I’m on a Windows developer computer) but with error “Network is unreachable”.
I connected directly pc and module with an ethernet cable.
In the module /etc directory I don’t have any ssh subdirectory…
Does it means it is not installed?

At point 2 I usually change the eth0 address to with “ifconfig eth0”. (it usually work fine in my experience).
I made the same thing today without changing ip and the ssh connection works!
What in this ip modification goes wrong?

anyway I performed a device test in Qt and everything is ok but the “rsync”.

How can I set a “static” (or almost constant) ip address to my board alterntive to ifconfig?

Today I tested connmanctl command. It works changing the static desired ip but after this changing I cannot ping to the device.
I used the command:
connmanctl> config ethernet_XXXXX_cable --ipv4 manual

But after this I cannot ping anymore.
Is there any other procedure to test?

I followed instructions in:


Hi @agalli !

You need to be sure that the module and the computer are in the same network, with compatible IPs and Network Masks. What is your computer’s IP and Mask?

Also, if you are specifically using the ping command, some company networks might block the ICMP protocol, therefore ping will not work even if all your setup is correct.

Best regards,

Hi @agalli!

Do you have any updates regarding this topic?

Best regards,

Hi Henrique,
only now I have found the error (I guess). My windows pc has ip with mask (just because company policy) , while on my board I was trying to set a ip mask.
Those ip are not in the same network, correct?
If I set the device to it seems to work fine (the device will never be online).

I usually need to switch my windows pc net connection between internet and device but I don’t have any better/faster solution.
Do you have further advice?

Hi @agalli !

Yes! You are correct.

For development, it is usual to have a local network where you are able to configure as you need. Of course you most probably need to align it with your IT, but being able to “mess around” with your own local network is veeeery helpful for development :wink:

And thanks for marking the solution :smiley:

Best regards,