Splash Screen with Colibri Imx6dl

Hi. I have successfully made splash screen working acording to this link. But with “quiet” kernel argument i see some console msgs instead of my image. If i disable CONFIG_PRINTK in kernel config it’s work fine, but i’d like to save dmesg. How can i use splash screen with “quiet” argument?

Also with disabled CONFIG_PRINTK some boot msgs start printing in the middle of booting at the left bottom corner

and remain until my app starts

Best regards, Dmitry

Dear Dmitry,

you are on the right track. Further down on the article you were following you’ll find the “Disable Framebuffer” section which hints you in the right direction.

I added a second link which when you follow it brings you to a full article about framebuffer disabling and redirecting. By redirecting it you can still access all the data, without it beeing shown on your screen.

Splash Screen | Disable Framebuffer

Framebuffer full Article

Let me know, if this will help you proceed.

Best Regards

Hi @kevin.tx. I have already disable framebuffer with this command:

  1. setenv setup “setenv setupargs
    consoleblank=0 no_console_suspend=1

And yes its remove all printing while kernel loading. But when /sbin/init starts i see first blinking cursor, then msg “Please wait booting…” and then console logging untill my qt app starts. i’d like to note that i use sysvinit instead of systemd, maybe this is the cause of the problem.

I have recompiled image with systemd and now i don’t have any msgs while booting, but i’d like to use sysV since it significantly reduce boot up time.

Hello @shkipper12 ,

Thank you for your ‘update’ part. It makes sense now. Unfortunately, we do not support SysV, so we cannot help you much there. But you can use sysV if it is really needed for your application.

Best Regards,

Hi @saijanani.tx. I found out all unnecessary print logs in different initscripts and comment them. Now all works fine with sysV.

Hello @shkipper12 ,
Thank you for your update! I am glad it worked
Best regards,