Splash screen logo for kernel 4.14.x Colibri imx6

Hello @jaski.tx

As suggested in this post we used steps to change the splash screen for yocto based linux it worked fine with with kernel 4.1.x, but when we upgraded kernel 4.14.x. We are not able to get the splash for kernel?

Carrier board: colibri imx6

Kindly guide us

Hi @yatish.m

Welcome to Toradex Community.

I quickly tested with the attached bbappend file and it is working.
Please refer to the link text for more information on Creating custom layer and kernel recipe.

@ashok.tx ,
if we enable deletion of temporary workspace with below variable, your suggested solution will still work?
INHERIT += “rm_work”.


Hi @yatish.m

Yes, It should work.

Hi @ashok.tx ,

We tried the approach you mentioned and we dont see splash screen coming up.
When we tried to check the LOGO flags and I have output attached the output of
zcat /proc/config.gz | grep LOGO.

We also verified the logo file was copied to the build directory.
Please let us know how to debug the issue.

Hi @yatish.m

Hope you have disabled the Frame buffer console .the Display and splash screen image resolutions are same?if not adjust the display resolution in u-boot using vidargs environment variable.

Hi @ashok.tx,

We are using the same splash screen logo and display resolution that worked for us with kernel 4.1.x and we have disabled framebuffer and also attached the logs for the same.

Hi @yatish.m

Framebuffer console support is disabled in boot2qt kernel configuration. To enable the Framebuffer console in the kernel, add the below lines to linux-toradex_4.14%.bbappend file.

    echo "CONFIG_DUMMY_CONSOLE=y" >> ${B}/.config
	echo "CONFIG_FRAMEBUFFER_CONSOLE=y" >> ${B}/.config

linux-toradex_4.14%.bbappend (991 Bytes)