SpiDev fail when set SPI_LSB_FIRST


I’m trying the spidev-test utility but when i configure the SPI_LSB_FIRST option the SPI_IOC_WR_MODE ioctl call with the value 0x08 which turns on the SPI_LSB_FIRST flag fails with message:

can’t set spi mode: Invalid argument

Does anyone have any idea what the reason could be?.

Thanks for the help

Best regards

Flavio Gobber

Hi @flavio ,

Thanks for your question.

Could you please state which BSP version you’re using?

Best Regards

Hello Kevin,

I found in other response that the driver support that option but the soc imx8 doesn’t support it.
I have changed my configuration and I can work.

Thank you


Hello @flavio ,
Thanks for your feedback.
Can you please post the link to the answer that solved your issue and mark your post with the link as a solution?

Best regards,