Silent import .reg files

Hi, I can’t do silent import .reg file in WEC6 1.4beta2.
Later, on PXA320 and VF61 until WEC6 V1.3 build inclusively, I ran:

“rapistart.exe pregedit.exe -s \FlashDisk\backlight.reg”

and it worked fine without dialog box.

Now, I trying to run:

“rapistart.exe regedit.exe /S /FlashDisk/backlight.reg”

and getting dialog box. Also I getting message: “setValue failed to open key HKEY_CURRENT_USER\ControlPanel\BackLight”

Does anyone have any ideas?

Can you please sent us reg file.

link text

We switched to same registry editor on all platforms we have. Seems that new one has some issues with silent. I will provide you new version later today.

Can I get new version?

There was a delay in building new regedit. I will post here as soon as I have working version.

Here you can download new registry editor →

When importing entries you have to type full path, for example if you have file on USB HD

regedit.exe /S “USB HD\backlight.reg”

I installed this regedit.exe but it goes to an endless loop when called from a command line if I try to import the following lines from a .reg file (Colibri iMX6 WEC2013 Image 1.1):

Windows Registry Editor Version 5.00
"04a1001aRegisteredServices"="00000000=A8512652-48D7-48A6-A8BA-6A58577A8308 "

Do you have an updated version of regedit.exe?

Can you please upload .reg file to and post a link here. This way also line breaks are preserved and we can test it.


link to exp.reg:


Please try our updated regedit application and let us know if it is not solved.

On a WEC2013 command prompt:
Cannot execute regedit.exe
Is this a CE8 version?

On a WEC6 v 1.4beta2 Colibri VF61 256Mb IT V1.2a it works. The issue was fixed.