Serial4 Cannot open ComPort

We are having problems opening communication on Com4.
I did as described in the article about Serial Ports and copied a serial port in registry and adjusted the index etc.

However I am still not able to open this port to communicate over it.

Am I overlooking something here?
These are the settings I have for the port in registry settings:

Prefix                        COM
Dll                             libnvuart.dll
Order                        0x00000004(4)
IClass                       {A32942B7-920C-486b-B0E6-92A702A99B35}
DeviceArrayIndex     0x00000083(131)
Index                        0x00000004(4)

Kind Regards,

Your data looks ok. I quickly tried to reproduce this but it worked all fine for me. To make sure we have the same setting, I exported the registry config I have used, you can get it from here.

The port was loaded in the bootloader debug output:

Loading Serial4(UART_D)...Done Serial4(0)

As well as I was able to list and open the port.

If you still have any issues, please let us know what actually fails and also check the debug output.

Hi Samuel,

Your fix worked.
I had copied the complete Serial3 settings, including the subfolder.
After deleting this and applying your registry settings it worked.

Thanks for the help!

Kind Regards