Serial device permissions are not permanent on the Colibri imx8

Hopefully not just a simple linux issue, but we’re using the Colibri iMX8 with a custom image for a new project. It’s connected to a serial rfid reader on UART A on device ‘/dev/ttyLP3’. This defaults to -

crw–w---- 1 root tty 239, 3 Jul 13 13:15 /dev/ttyLP3

and has a symlink to -

lrwxrwxrwx 1 root root 6 Jul 13 16:21 /dev/colibri-ttya → ttyLP3

Works fine running some test rfid code and my dev app as root, but I’m getting a permissions error when
running as our production user because ttyLP3 is group W, not group RW (I added this user to the tty group, but still no go).

  • created a udev rule to set permissions, it runs a few times but then reverts back to the permissions above.
    (udev has worked fine in the past, but the permissions here keeping changing back)
  • I’m starting to think UART A on the imx8 is the issue…would another one be more appropriate to use?
  • are the permissions for that device configurable in the device tree for me to change?


Can you repro this issue on a Toradex provided OS image? If so could you describe detailed repro steps?

Although I think it’s strange behavior for the permissions for UART A to do that, I just used UART C instead. I’ve written a few udev rules files for the imx7 which always worked as expected.

I will try it with a Toradex image and see what happens…thanks.


For what it’s worth, I booted up a board today using an Iris carrier board and could not reproduce this. I tried both our Torizon image and our Reference Multimedia image. In both cases the /dev/ttyLP* nodes were permissions 660 with root owner and dialout group.