SD card is not found after rebootart

Colibri T30, WCE7, BSP 1.4

Dear Ladies and Gentlemen,

I use an 8GB SD card, which is formatted in extFAT.

I have the problem that after a reboot sometimes the card is not recognized.

The problem also occurs after flashes of an image.

Would be very nice if you can help me.

Best regards.

Saphymo

A small addition to the above problem:

The SD card is disturbed by the operating system if the power supply is interrupted during a write access.

Is there a way on the part of Toradex to solve the problem?

Thank you very much

Saphymo

@Syphymo: What do you mean with “disturbed”? If you reinsert the card after it is not seen after a reboot, is the data still corect on the card? Did you once enable the Debug Output and check if there is any difference it it works and if it does not work? Probably the controller of the card is in a locked state if the board gets powered down and needs to be reset by powering it off. If this is the case you probably never would see the issue if you make a full power off and not only a reset?

Dear Samuel.tx,

Thanks for your quick reply.

I use a micro SD card, Therefore, a violation is excluded.

The SD card is no longer readable after the error, Only one repair on a desktop PC can restore the data, sometimes just helps format it.

The error occurs when the T30 is reset or taken from the current.

Did you also check with TexFAT or TFAT (transaction save)? You can format the device as TFAT / TexFAT on your colibri directly, check this how to.

Dear Samuel.tx,

thank you for your reference. I will try it.

Do you know if I can use the Storage Manager without the mouse and keyboard? About .bat or other programs (.dll, header …)

I am not aware of any bat / command line tool. You could use the Storage Manager functions API, which is documented on MSDN.

Beautiful good day,

thanks again to Samuel.tx. I have tried the following description:

http://developer.toradex.com/knowledge-base/flash-file-system#Format_external_storage_device_with_TFAT

Unfortunately without success.

Furthermore, the Flash also makes problems by the platform completely fails.

What am I doing wrong?

The SD card or flash is no longer displayed in the event of an error.

Many thanks for your help.

Best regards

Saphymo

@Saphymo: I think we have to further understand how this issue is triggered. Is there a way how to reliable reproduce this issue? Could you give us a guide how we can get into the same situation on our baseboard and the standard image?

Good afternoon Samuel.tx,

thank you for your response.

The problem is easy to adjust. I have already observed it with the current image of Toradex.

You need a software that writes continuously to the SD card / Flash.

Furthermore, you need a unit which switches off the power of the T30 board independently of the write operation.

If the interval is 1min, the error should occur within one day.

It is best to write 2 writing software. In C ++ and C #

Best Regards

Saphymo

@Saphymo: Are you using industrial grade SD Cards that guarantee to be power fail save (i.e. swissbit, cactus or others)?

Hello Samuel.tx,

we are using industrial grade SD Cards that guarantee to be power fail save.

@Saphymo: The Community Issue 4244 as similar. We have been able to reproduce the issue of the customer but on image 1.4. The description of the issue is slightly different. On image 2.0 beta 3 or beta 2, we have not been able to reproduce it any longer. Also the customer confirmed his issue is fixed with 2.0 beta 3 (post of the 29th of November 2016). We currently do not know what could have fixed the issue and need to do some further investigations. If not already done, would you mind test with Image 2.0 beta 3 once? If you don’t see the issue any longer, this could be the same issue as reported in 4244. We on our side will do some more investigation in order to find out what could actually could have fixed this issue (MS Updates, chnages on our side, …).

Dear Toradex Team,

I have now tested the beta 2.0 image of Toradex (T30).

The problem also occurs there. Folders are deleted or the SD card is no longer readable.

Would be very nice if you could help me.

Best regards

Saphymo

If I remember right, this issue is still not reproducible easily on your side?

We are currently investigating a similar issue. Also we have not seen it on 2.0 beta 1 images an later, we don’t think the issue we are investigating is actually solved. It is hard to say until when we have a patch for this issue, I guess it will be in the following two weeks. I will send you an updated driver once is ready, so you can test with that.

Dear Toradex Team,

I have a case where a debug message was produced:

SMP: Active CPUs = 4
Extended Mem : 0xA0000000:0xBFFFFFFF
Chip Id: 0x30 (Handheld SOC) Major: 0x1 Minor: 0x3 SKU: 0xb0
NURM Initialized shmoo database
PllClocks(Mhz): X=130, M=533, C=600, P=408, A=24.576
SysClocks(Mhz): CPU= 1300, AVP=240, SysBus=240, Mem=266, EMem=533
GraphicsClocks(Mhz): Host=106, 3D=88, 2D=88, Epp=88, Mpe=88, Vde=408
Loading FlashFileSystem(eMMC)…
Done FlashFileSystem(eMMC)(79)

I hope it helps you further.

Best regards

Saphymo

Hello Toradex Team,

I would like to test the SD card with the recommended registry settings of Toradex.

Can you give me a recommended registry setting?

Many Thanks

Best Regards

Saphymo

@Saphymo: Generally no settings are needed for SDIO. We once have seen that there is an issue with an industrial brand card with a timeout (industrial grade cards may be do deeper tests of the flash health when starting up). To fix that issue we introduced a key “PowerUpDelay”. You find the details here.

In this issue you have also reported issues with data corruptions. This will not solve this issue but only the not mounting issue.