Run Xserver on colibri imx7D with Yocto 5.0 mainline

My goal is to run some QT app on colibri +iris on yocto 5.0 + toradex resitive touch 7"
I built the tdx-reference-multimedia-image with the tdx-x11-upstream distro and colibri-imx7-emmc machine with no errors.

when i boot i see all the kernels logs and a prompt on the screen. I tried to launch some of the examples in /usr/share/ , like cinematicexperience, smarthome but always end up with :

root@colibri-imx7-emmc:~# /usr/share/cinematicexperience-1.0/Qt5_CinematicExperience 
qt.qpa.xcb: could not connect to display :0.0
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: minimal, offscreen, vnc, webgl, xcb.


I found that serverX is not started and wont start…:
logs are in the file attached => it look like the serverX config is not good
Have you any lead to solve this ? is this a bug from 5.0 ?

I tried also the yocto 4.0 provided by toradex and it works well but the xconfig is different. I tride picking up the x config from yocto 4.0 in yocto 5.0 but it gave me another error… (ask if needed)

Thank you for your time,

using toradex-linux instead of mainline kernel solved the problem

Please note that we are transitioning away from X11 in the BSP 5.0 cycle.