RtcSync with Colibri T20 WinCE7 V1.2


I’m running a Colibri T20 module with WinCE7 Image Version 1.2 with an external RTC Epson RX-8564LC.
I face the problem that the date time information is lost on restart.
WIth V1.3 it works properly.

I checked the release notes for V1.3 and noticed entry 9836 - RtcSync Not Working for Non-Standard RTCs. Did this entry solving my issue?

Is it possible to have a patched RtcSync.exe for V1.2?

Thanks in advance!

Important Note: We recommend to use at least image 1.3 or 1.4 as in image 1.2 there have been some NAND flash memory Issues that have been solved in the mean time.

To try if the RTCSync from image 1.3 solve the issue, I have attached the tool from 1.3 image here. For a first try, just copy it to the device and let it run and see if the time remains if it is written with this one. If so, you can replace the RTCSync Tool in your image by copying the tool to \FlashDisk\System and change the name of the tool in the registry key [HKEY_LOCAL_MACHINE\init] Launch48=RTCSync_1_3.exe.

It could also be that some other modifications solved the issue. We made some small fixes in the kernel as well. If the updated RTCSync tool does not fix your issue, you probably have to go for image 1.3 or 1.4.

Thanks, using RTCSync 1.3 solved it.