RTC doesn't work on Ixora board

Hello I have a problem with RTC on Ixora board with apalis T30 on linux. Why does the clock work incorrectly after turning on the power? I execute the following commands and get errors.

    root@apalis-t30:~# timedatectl
    Failed to query server: Invalid argument

After that, I’m trying to read the value of the time with the RTC by running the command:

root@apalis-t30:~# hwclock -r
hwclock: RTC_RD_TIME: Invalid argument

But again I get an error.

Then I set the value of the RTC from the system clock

root@apalis-t30:~# hwclock -w

And get the following values after.

root@apalis-t30:~# timedatectl
      Local time: Fri 2017-06-02 16:47:56 UTC
  Universal time: Fri 2017-06-02 16:47:56 UTC
        RTC time: Fri 2017-06-02 16:47:57
       Time zone: Universal (UTC, +0000)
     NTP enabled: no
NTP synchronized: no
 RTC in local TZ: no
      DST active: n/a

But it’s not right.
At the next day after turning on the power it does not work again.
Why is this happening? What am I doing wrong?

What exact BSP version are we talking about? I assume you followed this article on our developer website and did put a battery, correct?

@stefan.tx

To be honest I don’t quite see the relation here.

I have read this article. Battery is put correctly. What is BSP?

BSP is Board Support Package. Please provide the output of

cat /etc/issue
root@apalis-t30:~# cat /etc/issue
.---O---.                                           
|       |                  .-.           o o        
|   |   |-----.-----.-----.| |   .----..-----.-----.
|       |     | __  |  ---'| '--.|  .-'|     |     |
|   |   |  |  |     |---  ||  --'|  |  |  '  | | | |
'---'---'--'--'--.  |-----''----''--'  '-----'-'-'-'
                -'  |
                '---'

The Angstrom Distribution \n \l

Angstrom v2014.12 - Kernel
root@apalis-t30:~# uname -a
Linux apalis-t30 3.1.10-gb496d09-dirty #16 SMP PREEMPT Mon May 29 16:19:52 TJT 2017 armv7l GNU/Linux

I recompiled the kernel manually from the sources some time ago