RS232 Serial communication UARTB on VF50 not working

I’m using RS232 with VF50/CE7. Until now we were using UARTA(COM1) and communication worked OK in both directions.
On UARTB(COM2) communication does not work correctly. Writing to port works OK, but receiving data does not. It seem like windows is not sending communication events properly. Communication event is send only first time so first message sent form terminal on computer is received. Any following message is lost.

The same source code was tested on module VF61 and T20 (CE7 V1.2) and there communication works well on both ports, COM1 and COM2.

I also downgraded module VF50 to CE7 V1.2 and results were the same: UARTB not working properly.

Regards

Your code works on VF61 and not on VF50? Is that correct?
Are you testing using our EVB or a custom carrier board?
Can you provide a small code snippet, showing how do you initialize the serial port (DCB, timeouts etc.)?
You talk about “Communication event”, are you using .NET Compact Framework?
I’m sorry to reply with more questions, but this would help us narrowing down your issue.
Thank you for your patience.

Code works on VF61 and not on VF50. On VF50 module code works on COM1 and not on COM2.
Testing was done on Colibri Evaluation Board V3.1A
I use Visual Studio 2008 to deploy and debug my App

I Use CSerialWnd class to open, close, waiting OnEvent…

This is how I initialize port:

	port1->Open(_T("COM1:"),0,0,false);
	port1->Setup(CSerial::EBaud115200,CSerial::EData8,CSerial::EParNone,CSerial::EStop1);
	port1->SetupHandshaking(CSerial::EHandshakeOff);

I put break point in thread which listens to events:

if (::WaitForSingleObject(m_hevtOverlappedWorkerThread,INFINITE) != WAIT_OBJECT_0)

This is my the entry point where I can start observing what is going on with serial port communication.
In case I use COM2 this break point is reached only first time. If I use COM1 this code is reached every time I send something over serial port.
I am quite new in embedded software. I hope I provided some useful information.

Do you use both ports at the same time or just 1 port at the time?

Can you please download this image and give it a try → https://share.toradex.com/2gdghpyspns3enl

Its only temporary solution that was not officially published.

Correction:
UARTB still not working OK. Writing to port works OK, but receiving data does not.
In previous comment I wrote that UARTB is working, but I forgot to test communication in other direction.
regards
Janez

Previous message:
I tried this image you sent me and UARTB is working OK.

Currently we are using one port at the time, but eventually we will use both simultaneously.

How ever, I noticed that after opening UART port (A or B), Windows Mobile Device Center looses connection.
regards
Janez

With new image UARTB is working.
Problem was also bug in our source code.

Hi,
I have a colibri VF50 and VF61 with a development board 3.1, i’m having a problem testing RS232 and RS485, could you please send me some info, or sources to make that test ? … here’s my mail : anasse.bentchich@gmail.com
Thank you

Please @Anasse open a new thread with your request and try to specify for what OS/language you need more information and what level of information do you need (basic info about how to open a port, configure it and send/receive data or more detailed and advanced things like how to use it as RS485?).