Root login failure in colibri imx6ull and colibri imx7d (ask password)

Hi !!!

I’m working on SOM’s of colibri IMX7D ,colibri IMX6ULL . I have build images for my target boards and flashed without any password for “root” login.It worked well for some duration but suddenly root login started to ask password(no password for my image build).Now i’m unable to login .

One way i tried is , i re-flashed the image and now working fine.Going through some forums i found it may be due low availability of memory in rootfs. So, what i tried is after re-flashing i copied file which logs the data continuously to increase the memory . After sometime memory size is full file stop logging data due to no available free space and I was able to login as root successfully(no password asked).

What made the login root to ask password is still unknown ???


Welcome to toradex community.
Have you done any changes to local.conf file and image recipe i.e reference multimedia image?if yes,could you provide the same.

Is it accessible from wild world internet?.. Even if it is only your warm and safe community, someone or somewhat like infected PC still could login and set password.

I’m observing only in some SOM Module’s while the same Image is released to production and other are working fine .I want to know what could be the reason behind the failure to ask password . Is any situation like this happened to anyone ??

Actually we have only one login and no password . During issue time it is asking password so unable to login . No it is not connected to internet .