RNDIS Windows CE8 connection slow to enumerate on PC

We have been working with the RNDIS connection between our CE8 Device and several different host PC’s (win7 and Win 10). We use the default Toradex image and change USB port to RNDIS, using the VID/PID from Microsoft [we update the device name and manufacturer].
What we are seeing is when the USB connection is made to the PC it quickly creates the RNDIS network interface and UDP packets can be sent across, however TCP routing can taking minutes to connect up. You can see this with CerDisp where you can see the IP address in the connect dialog but Cerdisp cannot connect for some time across the connection. You can see a similar behavior on a reboot of the CE system as well.

With attempts to set the CE side to a static IP address in the self assign IP range for MS. (169.254.x.x), the reboot connection will be quick but the reconnection of the USB to the PC is still very slow.

Has anyone any experience with forcing the RNDIS driver on the PC side to be static?
Is there a windows CE DHCP server that can be configured on the CE device?

Dear @EolsonSpesctroSci

WEC2013 does not provide any DHCP server. I’m also not aware of any 3rd party solution. However, a simple DHCP server is not very hard to write, so it is well possible that there is code around in the internet.

To achieve a quick RNDIS connection you should simply configure static IPs on both sides. I also configured the default gateway, even though I think this does not make any difference. I added my settings in the screenshots below:



I hope this helps.

Regards, and a happy holiday season

Andy, Thank you for this path. Is there a way to have the RNDIS (Local Area Connection) to persist after connecting and disconnecting the USB? It seems that sometimes windows reenumerate the network connection.

Dear @EolsonSpesctroSci
I’m afrad I’m not aware of any method to keep the RNDIS connection while USB is disconnected.
Regards, Andy