Resistive Touch Problem IMX7

Hello @andy.tx ,

I’m facing same problem in IMX7. Same setup runs good with VFXX and IMX6.

Did you find any solution for this? As per your below comment it was supposed to be solved in 2 months.

http://www.toradex.cn/community/comments/37043/view.html

Have you tried what was suggested at post you mentioned?

ie:

The first thing to try out is to reduce the “FirstConversionDelay” setting. Try 0 (128 us) or 1 (256us)

Reducing the “MedianFilterSize” setting can also help to reduce the delay a little bit.

Lastly “AcquisitionTime” can also be reduced to the minimum to reduce the delay even further if necessary.

For a description of the iMX7 Touich registry settings:
https://developer.toradex.com/knowledge-base/resistive-touch-screen#Registry_settings_supported_by_Colibri_IMX7*

@alex.tx
Isn’t FirstConversionDelay is just as boot time delay?

Please find attached a [upload|8CkC21M9CtHC7j3ZJD0z+mCUay0=]snapshot of touch settings I have configured. But still, it is not working.

Also see below waveforms for correct working touch and touch with issues.
[upload|DNs+UIZNxm5w7CVz944X2CfryEY=]

@alex.tx Awaiting your reply.

Kindly let us know if you could solve this problem. else will file RMA request.

Regards,
Kushal

The FirstConversionDelay has nothing in common with a boot time - https://developer.toradex.com/knowledge-base/resistive-touch-screen#Registry_settings_supported_by_Colibri_IMX7

I still don’t understand your problem.
Could you provide more details about your system behavior?
It doesn’t work at all? Or it works unstable? If so - please adjust touch panel registry settings as described above.

Dear @alex.tx,
If you could read again my original question, you will understand my exact problem.

It works unstable only on imx7. It works flawlessly on VFxx and IMX6.

Please see attached touch panel registry settings. I have tried all combinations.
link text

Could you please define “works unstable” ?

Ocassionally when tapping a button, the button graphic changes indicating the touch has been seen, but this doesn’t get through to the application so nothing actually happens in the application.