Reinstalling LINUX OS Apalis IMX6 board

Actually we have tried to flash Wince7.0 image on apalis imx6 board. But we are unable to communicate to board using Teraterm. Now we want to revert back to Linux OS but we have tried below commands
1.bootfrom usb
But after executing this commands its coming to an empty screen, Toradex easy installer is not displayed . Can u pls help us for reverting back to Linux.
Thanks in advance

Please download Toradex Easy Installer package to you development machine. Then follow instruction from here.

Hi @Admin,

That’s ok, nothing will come after the reboot command, you need to run the recovery file (for Linux host) / recovery-windows.bat (for Windows host). It will download Toradex Easy Installer to modules RAM and boot it from there. After then you will be after to see the list of available images. You can find out more details from the link shared with you.

After rebooting i was not able to type anything in teraterm window. if it good if you guiding me through the steps for running recovery-windows.bat file

Hi @Admin,

No need to type anything on your terminal after reboot command.
Just run the recovery file by clicking on it and it will boot the Toradex Easy Installer.
Make sure that you have done the necessary cable connections.

Hi @sahil.tx
since after executing “reboot” command the display connected to board becomes black and teraterm also not working. Can you please how to run recovery-windows.bat in this situation

Open folder on your development computer where you unpack Toradex Easy Installer package to and double-click on recovery-windows.bat

i was able to get toradex easy installer by following the steps mentioned by u.But toradex installer not displaying available images list .it is showing error alt text

Hi @Admin,

In the pic, you can clearly see the reason for the image list not showing up.
Ethernet No address assigned.

Toradex easy installer looks for the images on the server (which needs internet connection), USB, or SD Card. The images should be visible if you have any of these.

Also, you must be having images copied to the SD Card/USB drive downloaded from here in order to be visible in the picture shared by you

Hi @sahil.tx
I have downloaded one image of Linux OS and copied to USB. The installer is not showing the image file on display.
image file path:“

Hi @Admin,

It must be extracted before you copy it to your USB storage.

Did you do that?

Hi @sahil.tx
yes done extracted in Linux host system after that copied to USB

HI @Admin,
Did you download the image from here?
If not, please use this link to download Toradex Easy Installer compatible images

Hi @sahil.tx
I have done flashing from image in the link provided by you. Now the problem is iam not getting any logs from board in teraterm and display is blank. Expecting your reply

Hi @Admin,

Please recheck that the connection is proper and the terminal configuration (baud rate, stop bi, etc ) is configured properly. You can go through this getting started guide which will help you in cable connection and terminal settings.
Making it work should be easy as you were getting logs earlier.
You should also check whether the COM port selected is the one connected with your Apalis.

Hi @sahil.tx Actually the connections are same before and after power on. Before i was flashing i was getting logs, But after flashing image and power on I’m not getting any logs on teraterm

Hi @Admin,

What error it is showing?
Can you send me the screenshot of your settings?
Did you verify your connections and COM port?
Did you check in the device manager for the COM port?
Apart from connections, you need to configure tera term with the correct configuration. Did you verify that?
By default, debug messages come on UART A.
I tested it at my end and it is working.
Please debug it, it should not be a big task.
Refer to the getting started article and toradex easy installer article shared with you.

Attaching the screenshot of teraterm configurationalt text

alt text

connections to board

Hi @Admin,

Do you have any display connected?
Is anything displayed over there?
Try to reinstall the image and let me know the result.