RegFlushKey doesn't work

I am using Colibri T30 CE7 V2.0B2.

Making a change to the registry then calling RegFlushKey, rebooting, the changes are gone.

If I use the SaveReg tool then it is saved. I did not have this issue with V1.4.

For testing I created this key: HKEY_LOCAL_MACHINE\Comm\X=1 (DWORD) using the built-in RegEdit in Colibri Tools.

Please advise.

We recently changed from flash based hive registry to RAM based hive registry. RegFlushKey doesn’t work in that case. We already found this issue and fixed it in 2.0b4 see roadmap:
http://developer.toradex.com/software/windows-embedded-compact/t20-t30-wec-software/release-details?view=all&issue=22777
If you don’t want to update to at least 2.0b4 you can use a workaround for now, you can use the UpdateTool to save the registry via UI or through command line parameters: update.exe /f
See: http://developer.toradex.com/knowledge-base/update-tool#Command_Line_Interface

I ran into the same problem. Can’t find the issue in the release database. Is there any news about this error?

@TriUrs, I updated the answer above. We fixed the issue in 2.0b4. I also updated the link to the issue description which was wrong before.

Hi Roman. Thank very you!