Regedit export error 87 WEC7 2.0 Beta3 (module T30)

If I run “export all” command in regedit on fresh installation WEC7 v2.0 beta3, I got error:
regedit: Cannot display message for error 87, status 317

Exported file seems to be okay, but compared to exported file by pregedit (older tool brought form WEC7 v1.4) there are many keys missing. for example key:

[HKEY_LOCAL_MACHINE\Platform] “SoftRTC”=dword:00000001 is not exported by newer version of regedit, but i can see it by browsing registers by same regedit tool.

Module T30-IT inserted in Iris board.

Can you please have a look on this.
Thank you very much


We know the the registry editor is not perfect and are working on that. Unfortunately the previous version also had plenty of bugs and we did not had the source to be able to fix it. So we decided to go to this one. I quickly tried to reproduce your use case, but did not get the error message and the export also contained the SoftRTC key. I have tested with the clean 2.0 beta 3 image. Did you had any custom settings in the registry that may cause this issue?

Thank you for your testing. Yes, I forgot that only WEC7 image was fresh, but the registry not. I have made some modifications to the registry, which I wanted to export by regedit as a redeable backup. These changes are: Disabling RTC dll by renaming it, default time zone change, deleted desktop icons, added mass storage manufacture and product name, autohide start menu, different wallpaper, clock not showed.
You’re right, some of that has probably some influence on the regedit export function. I will now investigate it myself, but thank you for pointing me out, where the problem can be.

Best Regards