Recovery Mode Problem on Colibri iMX7d

We having a Colibri iMX7d with Voila plus, We tried to Entering Recovery Mode by shorting R49 with 10kohm nothing happens.

ls usb:

technomed@TECHNOMED-01:~/Desktop/Colibri_iMX7_LinuxImageV2.6.1$ lsusb
Bus 001 Device 031: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

I try to do ./ -d I have :

Colibri iMX7 rootfs detected
Put the module in recovery mode and press [ENTER]...

config file 

vid=0x066f pid=0x3780 file_name=mx23_usb_work.conf

vid=0x15a2 pid=0x004f file_name=mx28_usb_work.conf

vid=0x15a2 pid=0x0052 file_name=mx50_usb_work.conf

vid=0x15a2 pid=0x0054 file_name=mx6_usb_work.conf

vid=0x15a2 pid=0x0061 file_name=mx6_usb_work.conf

vid=0x15a2 pid=0x0063 file_name=mx6_usb_work.conf

vid=0x15a2 pid=0x0071 file_name=mx6_usb_work.conf

vid=0x15a2 pid=0x007d file_name=mx6_usb_work.conf

vid=0x15a2 pid=0x0076 file_name=mx7_usb_work.conf

vid=0x15a2 pid=0x0041 file_name=mx51_usb_work.conf

vid=0x15a2 pid=0x004e file_name=mx53_usb_work.conf

vid=0x15a2 pid=0x006a file_name=vybrid_usb_work.conf

vid=0x066f pid=0x37ff file_name=linux_gadget.conf

no matching USB device found

Actually We don’t know, what is going on, because we previous done recovery using this setup. Is there any other any ways to recover the nand.

Not sure whether 10kOhm is really enough, I usually short the pads, but only temporarily at boot time using tweezers or something similar. The Toradex Easy Installer article also has instructions how to enter recovery mode.

found the same error, no matching USB device found for shorting R49 on voila board or in module. we made sure that uart ttl works fine. Is there any ways to recover the nand

Are you running linux natively or in a VM?

We tried in both old linux machine(12.04) and newly installed linux machine(16.04) also. And not in VM

Oh I see, you are using the Carrier Board recovery mode. It should work for Colibri iMX7. However, the pad shorting on-module is easier and I just verified it is working with the Viola Plus (see Colibri iMX7 data sheet and the Toradex Easy installer article).

Make sure you have no USB device connected to the lower USB-A connector since the micro USB connector is shared with the lower USB-A connector…

We have already tried the shorting pad on-module but result still found the same error.

Can you also try a different USB micro cable? Some cables (e.g. phone charger cables) might not work…

And you do not see the module appearing in lsusb (as shown in the video?)

To be honest, I have no idea, it works here with the very same hardware… That the modules USB OTG port is broken is highly unlikely since it made it through our testing. Maybe if you can send me pictures and screenshots of your setup I can spot something which might be wrong.

Unfortunately USB OTG port is the problem, the module appearing some times. luckily we are able to entering the recovery mode but we are unable to recover module directly, we got Error like this even in linux imageV2.6.1. Instead If we using sdcard we able to run setupdate but got error in run update reading

528384 bytes read in 42 ms (12 MiB/s)                                           
NAND erase.part: incorrect device type in u-boot  

2.6.1 was a very early release for Colibri iMX7, I would recommend to use the latest 2.7b3 release.