Recovery Mode on IMX8QM not working

Hi, I am using an Apalis Evaluation Board with IMX8QM chip. I need to put my device in recovery mode, i have followed the steps mentioned here:
But my device is not going into recovery mode. Is there any method (like LED indication etc) to check if the board is entering recovery mode?
I have tried changing the cables but none worked.

Hi, I erased the eMMC and now the board is being detected.

But i am unable to download the easy installer:

Is there any way to confirm if the device actually entered recovery mode?
Are there any additional steps to be performed?

hi @hari,
From the screenshot it looks like you are using Linux on a Virtual Machine which is not recommended.
Please use a Linux host directly.
To confirm the recovery mode,

  1. Below is the output that I receive by typing command “lsusb” when it has entered into recovery mode
    Bus 001 Device 057: ID 1fc9:012f NXP Semiconductors (differ from module to module)
    I do not know how to check in a vitual machine setup.

  2. You will not get bootlogs that you usually get when module is booting normally.

Note : Please use your company email as this helps us in providing better support

Hi @sahil.tx,
I tried to do recovery mode on a linux machine and the device was listed same as before. Sharing screenshots:

Is there anything else we can do?

Hi @hari,
It means that your device has not entered into recovery mode. Here are further things you can check.

  1. First check if the module is booting normally with the help of boot logs.
  2. Cross check recovery mode procedure
  3. Make sure all the required connections are conected.(Client port and UART port)
  4. Check with a different cable.
  5. Check with a different COM port.
  6. Check with a different module.

Please share error logs, debug logs if it still does not work.

Hi @sahil.tx,
It workded, we cleared the emmc using the steps mentioned in this article:
After that, we ran the recovery script for windows and it worked.