Recovery mode imx6ull on aster carrier board


I try to get my 2 Colibri modules back to their initial state (showing the toradex easy installer) in order to install a custom rootfs on them but I can’t get the board to load the proper way.
I tried on Ubuntu and WIndows 7 with differents USB cables without success.
Here is what I get from lsusb when I boot normally:

Bus 002 Device 005: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

and from dmesg:

[185241.802346] usb 2-1.2: new full-speed USB device number 6 using ehci-pci
[185241.925988] usb 2-1.2: New USB device found, idVendor=0403, idProduct=6001
[185241.925993] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[185241.925996] usb 2-1.2: Product: FT232R USB UART
[185241.925999] usb 2-1.2: Manufacturer: FTDI
[185241.926002] usb 2-1.2: SerialNumber: A505ZEKJ
[185241.928737] ftdi_sio 2-1.2:1.0: FTDI USB Serial Device converter detected
[185241.928788] usb 2-1.2: Detected FT232RL
[185241.929267] usb 2-1.2: FTDI USB Serial Device converter now attached to ttyUSB0

After I reboot the linux (login as root → reboot), stop the bootloader (hit any key during boot delay) and enter bmode usb. Nothing change in lsusb and no new message in dmesg

Model: Toradex Colibri iMX6ULL 512MB Wi-Fi / Bluetooth IT V1.1A, Serial# 06388160
Net:   FEC0
Hit any key to stop autoboot:  0
Colibri iMX6ULL # bmode usb
resetting ...

but the recovery script fails:

bemac@desktop:~/Downloads/Colibri-iMX6ULL_ToradexEasyInstaller_1.8-20181019$ sh 
Downloading Toradex Easy Installer...
no matching USB device found

Downloading Toradex Easy Installer failed...

What could be wrong?
I tried shorting the 2 pads on the Colibri module as well without a better result. IS there something else to do when using the Aster carrier board?

Thanks for your help

Did you connect a second USB cable(X10 connector in Aster board)?
And be sure if nothing is plugged at lower part of Aster X( USB connector.

Hi Alex,

Yes that was it!
I plugged a second micro usb on X10 and it showed up as SE blank when I entered bmode usb in u-boot:

[696151.662320] usb 2-1.3: new high-speed USB device number 14 using ehci-pci
[696151.771897] usb 2-1.3: New USB device found, idVendor=15a2, idProduct=0080
[696151.771900] usb 2-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[696151.771901] usb 2-1.3: Product: SE Blank 6ULL
[696151.771902] usb 2-1.3: Manufacturer: Freescale SemiConductor Inc 
[696151.773529] hid-generic 0003:15A2:0080.0013: hiddev1,hidraw3: USB HID v1.10 Device [Freescale SemiConductor Inc  SE Blank 6ULL] on usb-0000:00:1d.0-1.3/input0

And the recovery-linux script recognized it.

Did I missed that information somewhere?
Otherwise, it could be helpful for others to mention it either in the getting started guide or directly in the tesi wiki

Thanks for the help

Perfect that it works. You are welcome.
We mentioned about the connection of second USB connection on Toradex Easy Installer Page, but unfortunately aster carrier board is not documented yet. We will try to do this for future.