Rcu_preempt detected stalls on CPUs/tasks:


The toradex reference multimedia image was working perfectly fine until last week. But now with the same sources, if I build a new image I am getting the below error during the boot. But I flash the image I build last week, it works fine. Nothing changed in the source code. What could be the issue?

[    2.025485] hub 2-0:1.0: USB hub found
[    2.030955] hub 2-0:1.0: 1 port detected
[    2.041040] sdhci-esdhc-imx 5b020000.mmc: Got CD GPIO
[    2.077539] usb3503 0-0008: switched to HUB mode
[    2.079681] mmc1: SDHCI controller on 5b020000.mmc [5b020000.mmc] using ADMA
[    2.084324] usb3503 0-0008: usb3503_probe: probed in hub mode
[    2.103751] imx6q-pcie 5f010000.pcie: supply epdev_on not found, using dummy regulator
[    2.108064] ci_hdrc ci_hdrc.0: EHCI Host Controller
[    2.113849] imx6q-pcie 5f010000.pcie: No cache used with register defaults set!
[    2.119837] ci_hdrc ci_hdrc.0: new USB bus registered, assigned bus number 3
[    2.152150] ci_hdrc ci_hdrc.0: USB 2.0 started, EHCI 1.00
[    2.152417] imx6q-pcie 5f010000.pcie: ERROR PM_REQ_CORE_RST is still set.
[    2.159975] hub 3-0:1.0: USB hub found
[    2.172935] hub 3-0:1.0: 1 port detected
[    2.183668] debugfs: Directory 'lvds1' with parent 'pm_genpd' already present!
[    2.193270] debugfs: Directory 'mipi1-i2c1' with parent 'pm_genpd' already present!
[    2.202501] debugfs: Directory 'mipi1-i2c0' with parent 'pm_genpd' already present!
[    2.211773] debugfs: Directory 'mipi1-pwm0' with parent 'pm_genpd' already present!
[    2.220859] debugfs: Directory 'mipi1' with parent 'pm_genpd' already present!
[    2.238554] input: gpio-keys as /devices/platform/gpio-keys/input/input1
[    2.253911] ALSA device list:
[    2.258360]   No soundcards found.
[    2.544121] usb 1-1: new high-speed USB device number 2 using xhci-hcd
[    2.567830] imx6q-pcie 5f010000.pcie: PCIe PLL lock timeout
[    2.717656] hub 1-1:1.0: USB hub found
[    2.722903] hub 1-1:1.0: 2 ports detected
[   23.740040] rcu: INFO: rcu_preempt detected stalls on CPUs/tasks:
[   23.747596] rcu:     1-...0: (14 ticks this GP) idle=b95/1/0x4000000000000000 softirq=85/85 fqs=1050
[   23.759458]  (detected by 0, t=5256 jiffies, g=-1043, q=10)
[   23.766495] Task dump for CPU 1:
[   23.771136] task:kworker/u4:0    state:R  running task     stack:    0 pid:    9 ppid:     2 flags:0x0000000a
[   23.783918] Workqueue: events_unbound async_run_entry_fn
[   23.790674] Call trace:
[   23.794511]  __switch_to+0x104/0x15c
[   23.799469]  0xcc0

I tested the same on imx6, it is working. The issue is with imx8x. Anyone knows the solution?

Hi @jesvinonnet !

Sorry for the delay.

Could you please share the output of tdx-info? (reference: Getting Device Information with Tdx-Info | Toradex Developer Center)

Also, which carrier board you are using? Please share its version.

Could you please test with the ready-to-use Toradex Reference Multimedia image from Toradex Easy Installer feeds?
Maybe you applied some change that is causing the issue. Testing with the image built by Toradex might help to find the issue.

Best regards,

@henrique.tx ,

sorry for the delay in replay.

I am not able to run the tdx-info as the device is not booting. But I have the output of this command before I get the error.

Software summary
Bootloader:               Unknown
Kernel version:           5.15.129-6.5.0-devel+git.c994561e08e2 #1 SMP PREEMPT Tue Oct 24 13:33:37 UTC 2023
Kernel command line:      root=PARTUUID=490bab11-02 ro rootwait video=imxdpufb5:off video=imxdpufb6:off video=imxdpufb7:off
Distro name:              NAME="TDX Wayland with XWayland"
Distro version:           VERSION_ID=1.0.0
Hostname:                 colibri-imx8x

Hardware info
HW model:                 Toradex Colibri iMX8DX on Colibri Evaluation Board V3
Toradex version:          0052 V1.0D
Serial number:            14714374
Processor arch:           aarch64

I am using the Iris carrier board. It’s version is 2.0.

When I run the Pre build images, it is working. It is the same case with my images as well. Then images that I build before October 31st are working. Both my custom image and Toradex reference multimedia image. But both the images that I build after November 1st are not working. (Don’t look on the dates, that I gave just for an indication. I mean after some date the images that I build on my Ubuntu 22 are not working. I didn’t make any changes on both. But on the same time, both image works on imx6.)

Dear @jesvinonnet

There was an issue introduced with this patch which affects your Colibri iMX8X version:

We fixed it in the meantime. So all versions after linux-toradex.git - Linux kernel for Apalis, Colibri and Verdin modules should work again.


1 Like


Thanks for your response. I will test it and will let you know

@stefan_e.tx ,

It is working now. Thanks