qtchart missed

I built and installed toolchain, image, packages and libraries according to:
Qt Creator to cross compile - Embedded Linux.
All works fine in my qt5/qml application except qtchart.
Seems package with qtchart module is missed.
What have I do to get qtchart work?

What exact hardware and software versions of things are you talking about?

I have the following qt stuff installed:

libqt5declarative-plugins - 5.9.6+git0+fa02271a18-r0
libqt5declarative-qmlplugins - 5.9.6+git0+fa02271a18-r0
libqt5declarative5 - 5.9.6+git0+fa02271a18-r0
libqt5sensors-plugins - 5.9.6+git0+30044c5a4a-r0
libqt5sensors-qmlplugins - 5.9.6+git0+30044c5a4a-r0
libqt5sensors5 - 5.9.6+git0+30044c5a4a-r0
libqt5serialport5 - 5.9.6+git0+0a242c4940-r0
libqt5xmlpatterns5 - 5.9.6+git0+4dcae15a5a-r0
qtbase - 5.9.6+git0+9c50112304-r0
qtbase-plugins - 5.9.6+git0+9c50112304-r0
qtconnectivity - 5.9.6+git0+513e69bd6a-r0
qtconnectivity-qmlplugins - 5.9.6+git0+513e69bd6a-r0
qtdeclarative - 5.9.6+git0+283a900c4e-r0
qtdeclarative-plugins - 5.9.6+git0+283a900c4e-r0
qtdeclarative-qmlplugins - 5.9.6+git0+283a900c4e-r0
qtlocation - 5.9.6+git0+b0dd210c2d_8c1be4ec01-r0
qtlocation-plugins - 5.9.6+git0+b0dd210c2d_8c1be4ec01-r0
qtlocation-qmlplugins - 5.9.6+git0+b0dd210c2d_8c1be4ec01-r0
qtquickcontrols2 - 5.9.6+git0+c48b314ede-r0
qtquickcontrols2-qmlplugins - 5.9.6+git0+c48b314ede-r0
qtscript - 5.9.6+git0+bc1c3fb95c-r0
qtwebkit - 5.9.6+git0+bd0657f98a-r0
qtwebkit-qmlplugins - 5.9.6+git0+bd0657f98a-r0
...

“qtserialport” was not included in the build by default and I had to add “IMAGE_INSTALL_append = “qtserialport”” option to my local.conf.

Is there a way to configure the build to get “qtchart” ?
Linux version is:
Linux colibri-imx6 4.9.87-2.8.3+g07d40f6f #1 SMP Tue Jun 26 20:21:42 UTC 2018 armv7l GNU/Linux

I use Linux x86-64 qt5.9.5 and QtCreator 4.6.1, downloaded from qt, for prototyping. “Qtchart” present out-of-the-box In this situation.

Pls. Do you have any suggestions?

hi @Serg

Thanks for the Information. You need to add qtcharts to your OE_build.

Thank U very much! Would be U so kind to describe what exactly should I do for it? Which options have I add to configuration files?

You are welcome. You need to add this to your local.conf before doing the openembedded build.

IMAGE_INSTALL_append = " qtcharts"

Still no qtcharts :frowning:
My local.conf in attachmentlink text

The problem is solved. Unfortunatly I had manually build qtcharts module from the sources and populate results to the target with scp. This is not good practice.
I’d like to know what I did wrong when I built with yocto?

Hi

Did you try to add the space before qtchart that Jaski proposed?

i.e. 'IMAGE_INSTALL_append = " qtcharts"

Max

Ops! I really missed the space. Thanks! I will try to rebuild.

Thanks for the Information. Let us know once you finished building.