QT SDK in wayland

Hello All,
I wanna implement a UI demo on reference-Multimedia image using Qt
Using the device tree overlay I was able to get output on the LVDS 10" display and HDMI(Dual Screen)
How can I display a QML Or Qt application full screen on the LVDS and HDMI Extend Mode wayland !!
Best regard!!

Hi @hhami ,

I am not sure if I understand your use-case exactly right.

By Extend mode and full screen you mean that the same application is stretching full screen over both screens? Or is it that you want to show the same application twice full screen on both screens?

Have a great day

Best Regards

Thank you for answering!!
I wanna add qt sdk to multimedia toradex reference yocto layer and then build it using bitbake!!
Toradex Reference-Multimedia-Image!!
How can i do that??
Best regards,

Hi @hhami !

To build an SDK using Yocto/OpenEmbbeded, please refer to the Linux SDKs | Toradex Developer Center article.

Best regards,

Thank you for answering
I added
IMAGE_INSTALL_append = " nativesdk-packagegroup-qt5-toolchain-host "
to local.conf and then execute command

bitbake tdx-reference-multimedia-image

but i faced this error:

 bitbake tdx-reference-multimedia-image 
Loading cache: 100% |############################################| Time: 0:00:00
Loaded 3918 entries from dependency cache.
NOTE: Resolving any missing task queue dependencies

Build Configuration:
BB_VERSION           = "1.46.0"
BUILD_SYS            = "x86_64-linux"
NATIVELSBSTRING      = "universal"
TARGET_SYS           = "aarch64-tdx-linux"
MACHINE              = "apalis-imx8"
DISTRO               = "tdx-xwayland"
DISTRO_VERSION       = "5.7.0-devel-20221102075140+build.0"
TUNE_FEATURES        = "aarch64"
TARGET_FPU           = ""
meta-toradex-nxp     = "HEAD:ee63c90fde9fde0229bff9ac1c5cffe356fc4f41"
meta-freescale       = "HEAD:3cb29cff92568ea835ef070490f185349d712837"
meta-freescale-3rdparty = "HEAD:c52f64973cd4043a5e8be1c7e29bb9690eb4c3e5"
meta-toradex-tegra   = "HEAD:f5753af4a5b9d33f0f474b320a74c2e29a66ec39"
meta-toradex-bsp-common = "HEAD:029a663150449a5e71b84dd4000476754d525c8c"
meta-python          = "HEAD:8ff12bfffcf0840d5518788a53d88d708ad3aae0"
meta-freescale-distro = "HEAD:5d882cdf079b3bde0bd9869ce3ca3db411acbf3b"
meta-toradex-demos   = "HEAD:ce3c1925df34b4d299b2dd1003ced41b9485ce41"
meta-qt5             = "HEAD:5ef3a0ffd3324937252790266e2b2e64d33ef34f"
meta-toradex-distro  = "HEAD:cbde0286cb85bc445e70210b8df38f29b4784c08"
meta-poky            = "HEAD:7e0063a8546250c4c5b9454cfa89fff451a280ee"
meta                 = "HEAD:add860e1a69f848097bbc511137a62d5746e5019"

Initialising tasks: 100% |#######################################| Time: 0:00:12
Sstate summary: Wanted 1148 Found 1144 Missed 4 Current 2758 (99% match, 99% complete)
NOTE: Executing Tasks
ERROR: tdx-reference-multimedia-image-1.0-r0 do_rootfs: Unable to install packages. Command '/home/user/oe-core/build/tmp/work/apalis_imx8-tdx-linux/tdx-reference-multimedia-image/1.0-r0/recipe-sysroot-native/usr/bin/opkg --volatile-cache -f /home/user/oe-core/build/tmp/work/apalis_imx8-tdx-linux/tdx-reference-multimedia-image/1.0-r0/opkg.conf -t /home/user/oe-core/build/tmp/work/apalis_imx8-tdx-linux/tdx-reference-multimedia-image/1.0-r0/temp/ipktemp/ -o /home/user/oe-core/build/tmp/work/apalis_imx8-tdx-linux/tdx-reference-multimedia-image/1.0-r0/rootfs  --force_postinstall --prefer-arch-to-version   install bash connman connman-client connman-plugin-ethernet connman-plugin-loopback connman-plugin-wifi coreutils gpicview less makedevs media-files mime-support nativesdk-packagegroup-qt5-toolchain-host net-tools opkg packagegroup-base-extended packagegroup-base-tdx-cli packagegroup-basic packagegroup-boot packagegroup-core-boot packagegroup-fsl-isp packagegroup-machine-tdx-cli packagegroup-tdx-cli packagegroup-tdx-graphical packagegroup-tdx-qt5 packagegroup-wifi-fw-tdx-cli packagegroup-wifi-tdx-cli run-postinsts systemd-analyze timestamp-service udev-extraconf util-linux v4l-utils wayland-qtdemo-launch-cinematicexperience weston weston-examples weston-init weston-xwayland xterm' returned 255:
Collected errors:
 * opkg_prepare_url_for_install: Couldn't find anything to satisfy 'nativesdk-packagegroup-qt5-toolchain-host'.

ERROR: Logfile of failure stored in: /home/user/oe-core/build/tmp/work/apalis_imx8-tdx-linux/tdx-reference-multimedia-image/1.0-r0/temp/log.do_rootfs.108369
ERROR: Task (/home/user/oe-core/build/../layers/meta-toradex-demos/recipes-images/images/tdx-reference-multimedia-image.bb:do_rootfs) failed with exit code '1'

Hi @hhami,

I believe you just need to follow the steps from Linux SDKs page @henrique.tx is referring to in his response. The reference multimedia image should have everything you need to create SDK files.
Honestly, I do not think that IMAGE_INSTALL_append = " nativesdk-packagegroup-qt5-toolchain-host " is the way how you do it. When I was preparing SDK files for my Colibri IMX8X, I simply followed the page from @henrique.tx link. And it worked.

Wish you success.

1 Like

Hi John1
Thank you for answering
I built it and it works good for qt application
but i wanna use QML(QtQuick) in Cross Compile SDK
i cant use Qtquick when i wanna create a project using QT Quick Application(new project)

Qtcreator said No suitable kits found.

and Qt kit setting is

any suggestion

Hi @hhami,

to cross compile your project, you have to create a suitable kit by yourself. I am not sure if the automatic detection of compilers works in this case. You have to read carefully this knowledge base article. It is the perfect guide for you.
The article presumes that you had installed generated SDK somewhere in your PC (also mentioned in the article).

One more thing regarding Qt Quick. I do not know what Qt version comes with BSP v5.7. You have to make sure that your nativesdk-packagegroup-qt5-toolchain-host.bb contains nativesdk-qtdeclarative-tools in the RDEPENDS_${PN} section.
If not, you have to create nativesdk-packagegroup-qt5-toolchain-host.bbappend file with this content:

RDEPENDS_${PN} += " \
nativesdk-qtdeclarative-tools \

This bbappend file has be located in a meta-layer (ideally in your custom layer) in the specific folder. So, in my case:
After that, rebuild you image. Bitbake should detect your changes and apply them.

I wish you success.

Thank you for your answer,again
I said it worked and it dosnt any problem
But now,i wanna build a QML application!!
Can you help me??

Hi @hhami !

That’s great that you got a working SDK.

It is not clear what you mean here.

What are you trying to build?
How you are trying to build?
You are trying to build and run on your computer or on the module?

Please give us more information on exactly what you are trying to do and which steps you are performing, so we can try to help you further :slight_smile:

Maybe you would find it a good way to try using TorizonCore, which has an easier workflow setup:

@hhami, I have answered your question before you edited it. You reported that no suitable kit was found by your QtCreator. I have provided you a link where you can find out how to properly configure a kit for the cross compilation.
The last image of yours showing the kit configuration looks odd a little. Below you can see my configuration for Generic Linux device, including the configuration of compilers, debugger, mkspec etc.


The knowledge base page from my link specifically describes the creation of a Generic Linux device´. The only thing I can recommend you is following that page. I have done it and I have a QML application running on my Colibri SOM. The project is uploaded to the device via Ethernet.

This is everything I can give you. I do not think there would be any major difference between Colibri and Apalis when it comes to Qt project configuration in QtCreator.

1 Like

What are you trying to build?
→ I wanna make a QML sample application
How you are trying to build?
→ I trying to make a QML sample application using QT SDK that i built it
You are trying to build and run on your computer or on the module?
→ I wanna to make crosse a QML sample application and run it on the module!!
but when i wanna create a new QML(Qt Quick Application on the Qtcreator) it says No suitable kits found.

John1 thank you
I edited setting using your config and changed qt version and finally it worked!!
Your are lifesaver!!

Hi @hhami !

Thanks for the feedback.

@John1, thanks for your help :smiley:

Best regards,

Thank you @ henrique.tx too
Appreciate that!!
Best regards,

1 Like