Qt SDK Build Failures

I am attempting to build the a Qt SDK according to the How to set up Qt Creator to cross compile for embedded Linux. I’ve built the Linux OS according to the OpenEmbedded (core) document. I deleted my original oecore folder and started from scratch by following the OpenEmbedded (core) document linked above. I was able to successfully build the embedded Linux OS without any errors, but this morning when I tried to build the Qt SDK it took about 1.5 hours. Towards the very end of the build I received the following errors:

ERROR: meta-toolchain-qt5-1.0-r0 do_populate_sdk: The recipe meta-toolchain-qt5 is trying to install files into a shared area when those files already exist. Those files and their manifest location are:
Matched in b’manifest-colibri-imx7x86_64-angstrom-qt5-x11-image.populate_sdk’
Matched in b’manifest-colibri-imx7x86_64-angstrom-qt5-x11-image.populate_sdk’
Matched in b’manifest-colibri-imx7x86_64-angstrom-qt5-x11-image.populate_sdk’
Please verify which recipe should provide the above files.
The build has stopped as continuing in this scenario WILL break things, if not now, possibly in the future (we’ve seen builds fail several months later). If the system knew how to recover from this automatically it would however there are several different scenarios which can result in this and we don’t know which one this is. It may be you have switched providers of something like virtual/kernel (e.g. from linux-yocto to linux-yocto-dev), in that case you need to execute the clean task for both recipes and it will resolve this error. It may be you changed DISTRO_FEATURES from systemd to udev or vice versa. Cleaning those recipes should again resolve this error however switching DISTRO_FEATURES on an existing build directory is not supported, you should really clean out tmp and rebuild (reusing sstate should be safe). It could be the overlapping files detected are harmless in which case adding them to SSTATE_DUPWHITELIST may be the correct solution. It could also be your build is including two different conflicting versions of things (e.g. bluez 4 and bluez 5 and the correct solution for that would be to resolve the conflict. If in doubt, please ask on the mailing list, sharing the error and filelist above.
ERROR: meta-toolchain-qt5-1.0-r0 do_populate_sdk: If the above message is too much, the simpler version is you’re advised to wipe out tmp and rebuild (reusing sstate is fine). That will likely fix things in most (but not all) cases.
ERROR: meta-toolchain-qt5-1.0-r0 do_populate_sdk: Function failed: sstate_task_postfunc
ERROR: Logfile of failure stored in: /home/carloval/Development/New_Products/Colibri_iMX7D/A7_0/Operating_System/Linux_Embedded/oe-core/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/meta-toolchain-qt5/1.0-r0/temp/log.do_populate_sdk.20432
ERROR: Task (/home/carloval/Development/New_Products/Colibri_iMX7D/A7_0/Operating_System/Linux_Embedded/oe-core/build/…/layers/meta-qt5/recipes-qt/meta/meta-toolchain-qt5.bb:do_populate_sdk) failed with exit code ‘1’

I have built the Qt SDK previously without errors. Why am I having an issue with this now? Last time, when this build did succeed, I was using:

bitbake -k angstrom-lxde-image

this time I built the embedded Linux OS with:

bitbake angstrom-qt5-x11-image

per the following forum post here.

It is not clear to me what I need to be cleaning, per the error message, to resolve this issue so that I no longer receive build errors when building the SDK. Do I just need to delete the files in the tmp-glibc folder? How do I resolve this issue?


UPDATE: I tried removing the tmp-glibc folder from /oecore/build/ and then running bitbake -k meta-toolchain-qt5 again. The tmp-libc folder is regenerated again, but I’m still seeing this error.

I got it working. Thanks for the suggestion though. I put back my original tmp-glibc directory, and then basically did what you stated, but I just deleted the 3 files in the ERROR messaging above and it worked.

Thanks Again.

Can you try again by deleting ~oe-core/deploy/sdk viz. the sdk directory. That should fix the issue you are seeing.

after deleting sdk directory, it doesn’t builds again. the sdk directory is neither created again and the build also fails

Would you please ask a new question exactly stating what issue you are seeing rather than hijacking an old question?