QT on Colibri VF50: QT Creator - building problem - "execvp: ../test_01/mainwindow.ui: Permission denied"

hi,
I want to create a QT application on a colibri VF50. I created the console-tdx-image and the meta-toolchain-qte . I entered the following commands (Qt Creator to cross compile - Embedded Linux) :

sudo apt install build-essential -y
sudo apt install qt4-default qtcreator -y
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install g++-5-multilib -y
sudo apt-get install curl dosfstools gawk g++-multilib gcc-multilib lib32z1-dev libcrypto++9v5:i386 libcrypto++-dev:i386 liblzo2-dev:i386 lzop libsdl1.2-dev libstdc++-5-dev:i386 libusb-1.0-0:i386 libusb-1.0-0-dev:i386 uuid-dev:i386 texinfo chrpath git -y
cd /usr/lib; sudo ln -s libcrypto++.so.9.0.0 libcryptopp.so.6
cd ~
mkdir ~/bin
export PATH=~/bin:$PATH
curl http://commondatastorage.googleapis.com/git-repo-downloads/repo > ~/bin/repo
chmod a+x ~/bin/repo
git config --global user.name "XXX"
git config --global user.email XXX
mkdir oe-core
cd oe-core
repo init -u http://git.toradex.com/toradex-bsp-platform.git -b LinuxImageV2.8
repo sync
. export
nano conf/local.conf
	select: MACHINE ?= "colibri-vf"
	add: ACCEPT_FSL_EULA = "1"
cd ~/oe-core
. export
bitbake -k console-tdx-image
bitbake samba
bitbake console-tdx-image -c populate_sdk
bitbake -k meta-toolchain-qte
../deploy/sdk/angstrom-glibc-x86_64-armv7at2hf-vfp-neon-toolchain-qte-v2014.12.sh
. /usr/local/oecore-x86_64/environment-setup-armv7at2hf-neon-angstrom-linux-gnueabi
echo $OE_QMAKE_CXX
qtcreator

I tried the console-tdx-image because the qt4e-demo-image is too big for VF50.
run setupdate
run update
angström runs!
Now I started qtcreator and followed the steps for creating device, add QT_Version, add G++ , add GDB, and create KIT. (Qt Creator to cross compile - Embedded Linux)
I created a new project and into *.pro - file i entered :

target.path = /root
INSTALLS += target

when i build and run the project , I get the error:

execvp: ../test_01/mainwindow.ui: Permission denied

What can I do to successfully build a QT application on the VF50 ?!

Hi @stsemant

Could you provide the software version of your module?

Thanks and best regards,
Jaski

Unfortunately, I do not know exactly what you mean by software version of the module, so I write everything that comes to mind:

# U-Boot 2016.11-2.8.6+g83a53c1 
# LinuxImageV2.8 
# backports-kernel-module ... colibri_vf 4.19-r0 
# kernel-module ... colibri_vf 4.4+git0+6f01eb5bf8-r0
# util-linux ... armv7at2hf-neon 2.30-r0
# alsa-utils ... armv7at2hf-neon-vf60 1.1.4-r0

Dear @stsemant,

In order to resolve the “Permission Denied” issue, you need to fix the access rights for your project files. The following link might be helpful:

https://stackoverflow.com/questions/34635653/setting-read-write-permission-with-qfile-setpermissions

Also, Have you tried to run the application with Desktop as target and check if it executes successfully?

Thanks and Regards,
Janani.

When I run the application with the desktop as the target, it works fine.

I think I misrepresented my problem. I have the access problems not for a file that I want to access in the VF50, but for the VF50 itself. I mean the creation of the executable file (building) on ​​the VF50. I do not know how the commands from the website c++ - Setting read write permission with QFile().setPermissions() - Stack Overflow could help me or where to write them. In main.cpp?

Hello @stsemant ,

Thank you for your patience. I tried to run my custom Qt application on Target and was able to do so successfully. I did not encounter any “Permission denied” issue.

Could you please kindly check your Qt Kit, debug and compile configurations for the Embedded Linux. I also noticed there are issues when the application compiled for x86 (Host computer) was made to run on the Target (Improper assigning of the toolchain) while running the Qt embedded Build/run set-up.

Best Regards,
Janani.