Qt creator imx7d Deploy Libraries

Hi

In Qtcreator i have the following error issue. Deploying started, but the application cant

start on the device. In my opinion the Qt libraries should deployed with the app.

Output in Qtcreator is after deploing:

Debugging starts
Listening on port 10000
Remote debugging from host 192.168.10.50
Process /opt/test//test created; pid = 663
Could not load shared library symbols for linux-vdso.so.1.
Do you need “set solib-search-path” or “set sysroot”?/opt/test//test: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory
Child exited with status 127
Debugging has finished




thanks for any help

What can i do, to finally bring qt to live on my imx7d module???

Did you deploy an image on iMX7 module which has Qt libraries installed? For example, angstrom-qt5-x11-image?

No, I had copied all qt libraries to /usr/lib which i found in my oe-core stucture.
So where can i find the angstrom-qt5-x11 image? Or do i have to build it self?

You forgot about building/deploying the target image for Qt as explained in the following article on our developer website.

Nope, I did the step which marcel.tx described.

I’m afraid there are no libraries on the target.

Output by debugging is:

Debugging starts
Listening on port 10002
Remote debugging from host 192.168.10.50
Process /opt/test/test created; pid = 1471
Could not load shared library symbols for linux-vdso.so.1.
Do you need “set solib-search-path” or “set sysroot”?/opt/test/test: error while loading shared libraries: libQt5Widgets.so.5: cannot open shared object file: No such file or directory
Child exited with status 127
Debugging has finished

But did you deploy/flash/install your Qt image to the target module?

you mean the zImage and the *.dtb?
that one in oe-core/deploy/images/colibri-imx7?
No, not yet…

So i just updated the kernel by “run setupdate” “run prepare_ubi” “run update_fdt” and “run update_kernel”.

But when i type in #find -name libQt* it don’t find any library…

You also need to update the rootfs using an image which has Qt libraries deployed.

No, you will need to really install that Qt image you built onto your module.

Can i use the rootfs which i have created by building oe-core?
Ok, i had flashed the module with “run setupdate” and “run update” which should also flash rootfs.

I took the on which i builded in oe-core which is described in “OpenEmbedded (core)”.

But i still havent any qt libraries by seaching:
#find -name libQt*

also in /usr/lib it hasn’t any occurance of qt library…
Do i have the cor rebuild and add the Qt layer?

Yes, you will have to add the Qt layer or build an image target which includes Qt like the following.

Ok, I folowed the document :

http://developer.toradex.com/knowledge-base/board-support-package/openembedded-(core)#Adding_the_Qt5_Layer

to include the Qt layer.
Another question is, where can i change the display resolution in this kernel, which is

described on???:

http://developer.toradex.com/knowledge-base/display-output-resolution-and-timings-linux

this i have already done, and built the toradex kernel…

ENGINEERING - STEP BY STEP…