Python project does not work

Hi,
I’ve created from Toryson/Python template a python project in order to test a CAN Bus - How to Use CAN on TorizonCore

  1. I’ve got one step more than in the article and selected “Console application”. The other possibilities did not work for me - I’ve got an error message and the project was not vreated.
  2. I’ve started the project with F5, but got following messages:
    [04-27 13:03:57.072] Selecting device…
    [04-27 13:03:57.083] Please select a device.
    [04-27 13:04:07.499] No device selected, terminating debug session.

In the Torizon tab some strange additional device appiers (see attachment)
alt text

How I can solve this problem?

Hi @programmier-hirsch I think the first step is understanding why you don’t have a good connection to the Torizon device.

Is your device online and connected to the same network as your development system?

Do you have multiple network interfaces in your development system?

Can you post a screenshot of your entire VSCode window so I can see all the devices in the Torizon tab?

Drew

Are you using stable or early access version?
The problem with this “ghost” device is solved in 1.3.119 early access release.
If you plan to use Qt for Python you need to install pyside2 also in your local python environment because it install some tools required to auto-generate code from UI files. Maybe the error you see when starting debugging is related to this. If not, can you please copy and paste the error message you get in the “Torizon” panel inside the output window of VSCode? Thank you.

Thank you @valter.tx for the answer,
I do use a stable version of the extention and it really looks like the “ghost” device.
I have tried to use an early access version before, but It did not not properly work with ASP.NET Core, so I went back to the 1.2.0 version of the extention.
It’s definetely not a Colibri iMX8QXP/DX problem, bacause C# template works.

@drew.tx , in ASP.Net core project I don’t see any additional device and I can successfully deploy the image. In python project I cann see addtional empty image, nay be python extention didn’t set some properties?
link text

It seems that the issue has been triggered by a VSCode update that changed the behaviour of one of the libraries used by our REST API client.
You may revert VSCode to an older release or, I think better, move to an early access version. I think that the issues you mentioned with ASP.NET are solved there.
We will check if the fix we made in EA version may be applied also to the stable release, but this may require some time.

We backported the fix to stable release too.