PyQt5 in Linux

We use Colibri iMX6 DualLite 512MB V1.1A with Colibri Evaluation Board V3.2B.
We are trying to use PyQt5 with Embedded Linux V2.8 beta. We build a basic GUI form application using PyQt5. Compiling the python script in the host PC (ubuntu16.04) runs fine.
I tried installing Python 3 in the toradex using opkg and tried compiling the .py script using


and it shows me error

Import Error:No module named ‘PyQt5’

So I built an exe with it, thinking it may include all the dependency files. The exe is running fine in the host PC that I am using (Ubuntu 16.04). But if I execute the same in the Toradex board, it is not executing (nothing happens).

Isn’t PyQt5 a part of the Linux OS that Toradex offers?
I could see file inside the meta-qt5 layer. And meta-qt5 layer is present in the bblayers.conf file inside build folder in Yocto .
If it is not included by default, what bitbake command should I use to build an Linux OS to include PyQt5.

Or Is there any “Install_append” command to be included in the local.conf so that the PyQt5 is included in the Linux OS package?

We have already git cloned meta-mono layer and made it to execute an exe file generated by monoDevelop. And it worked perfectly.
We need resource to do the same for PyQt5.

Thank you for your time.

hi @goofy

We are trying to use PyQt5 with Embedded Linux V2.8 beta.

Could you provide the output of cat /etc/issue?

Please note that Qt is not available in standard LXDE or Console images but images with Qt included. You can include QT and PyQt in your custom image as explained here or you can install the demo Qt images using Toradex Easy Installer by activating the Feeds Server.

Best regards,