PXA270 bootloader fatal error 9 - Did not find valid image in flash!

My Colibri PXA270 wasn’t working properly so I wanted to re-flash it to ensure all system settings are correct and back to default. I tried recovering the bootloader over JTAG and ColibriLoader. But once it finished I reset the colibri and got these messages on the bootloader screen:

Unknown Product ID Version not set. SerialNo not set.
NOR Flash P33B: 32 MB, SDRAM: 64 MB
Core Voltage: 1250 mV
CPU: PXA270 M A1 312 (208), SYS: 208, MEM:208, SDRAM: 104, SRAM:208, LCD: 104
Set MAC: 00:14:2D:00:00 
Did not find valid IMAGE in FLASH!
Fatal Error: 9 

It doesn’t have the flash image and for some reason the Ethernet on my evaluation board isn’t communication.
I cannot get to the bootlader menu anymore.
What can I do to re-flash the image and get the Colibri to work?
Images are attached.

Dear @shiva_eghbal

There seems to be two different issues:

  1. The module lost the information in the Bootloader ConfigBlock.
  2. There’s no valid image in the flash

Let’s solve them one after the other.

First the ConfigBlock:

To restore it, you need the information printed on the module’s label (the one with the 2D barcode).

Enter the bootloader menu by pressing SPACE while powering on the device. Refer to my output below, which shows the correct configuration for a Colibri PXA270 520MHz.

Toradex Bootloader 4.5 for Colibri Built Jun 18 2015

Press [SPACE] to enter Bootloader Menu

BootLoader Configuration:

C) Clear Flash Registry
X) Enter CommandPrompt Mode
D) Download image to RAM now
F) Download image to FLASH now
L) Launch existing flash resident image now

Enter your selection: x

Config List:
* mac:          Ethernet MAC Address
* mult:         Clocks Multipliers
  ip:           IP Config
  boot:         Boot Config
  ser:          Serial Port Config
  loc:          Flash Locations (Layout)
  gpio:         GPIOs Config
  msc:          Static ChipSelect Timings
* hw:           HW Version
  dbg:          Debug Config
  mbs:          Memory Buffer Stength
  ss:           SplasScreen Config
  karg:         Kernel Arguments
  sd:           SD Card Config

>set mac
mac.tid:        0x0000142D      (Toradex MAC range ID)
mac.cid:        2680198         (Colibri MAC range ID)

>set mult
mult.l: 16              (RUN Clock = 13Mhz x l)
mult.n: 5               (Turbo Clock = RUN x n/2)
mult.t: 1               (Turbo Enable)
mult.b: 1               (Fast BUS)
mult.a: 1               (Alternate Mem Clock)
mult.k1db2:     1               (SDRAMClk/2)
mult.k0db2:     0               (FlashClk/2)
mult.k0db4:     0               (FlashClk/4)
mult.ht:        0               (HalfTurbo Enable)

>set hw
hw.vermaj:      2               (Major Version)
hw.vermin:      4               (Minor Version)
hw.variant:     0               (Variant Number (stuffing options))
hw.prodid:      9               (Product ID)
  • Enter a few commands (the ones after the prompt >) to check the current configuration. It will be wrong in your case.

  • Enter the following commands to restore the system information:

    set hw.prodid 9 // this means Colibri PXA270 520MHz
    set hw.vermaj 2 // the next 3 settings mean “V1.2A”. Please …
    set hw.vermin 4 // …adjust if you have a different version.
    set hw.variant 0
    save hw

    set mac.cid // is the 8-digit number printed on the label.
    save mac
    Also check the other settings and adjust them similarly to the correct values shown in my output.

Reflash Image

Use the ColibriLoader to re-flash the OS image over Ethernet

Regards, Andy

Hello Andy,
I did the first part with the config block.
Once I was done I reboot the Colibri and same error was produced again and Colibri serial number still set to 0.
What should I do after I set the correct values before moving on to reflashing the image?

Hi @shiva_eghbal

Try to erase the config block first:

>eraseflash configblock

and make sure you didn’t miss the save commands of my previous instructions.

With the basic command set (no parameters) you should see an asterisk * in front of each section which you had saved before.

Regards, Andy

Dear @shiva_eghbal

I moved your follow-up question into a separate post:

Regards, Andy