Pulling container vscode


I am facing an issue with the toradex vs code extension to pull a container.

My configuration is :
Iris v2 carrier board + imx8dx 1gb wb

I am currently having a Qt (c++/qml) project workspace on Vs code. All the development set up is done, using the toradex extension and working in a dev container.
My board is correctly connected through ssh and recognized.

My problem is :
When I try to debug my code, using the “start debbuging” button (or F5), I can see in the output logs :
[02-29 13:47:49.425] Pulling weston (torizon/weston-vivante:2)…

[02-29 13:47:49.489] Get “https://registry-1.docker.io/v2/”: dial tcp: lookup registry-1.docker.io on dial udp connect: network is unreachable

I tried bunch of things (changing connexion, reboot, checking firewall…) I really miss what is happening here.
The container is never pulled.

Can you help/advise?

Thank you

Hi @jrocher ,

Welcome to our community! Feel free to look at other topics of interest.

About your issue: How is the SoM connected to the network: via Ethernet cable or through Wi-Fi?

As a sanity check, can you manually pull the torizon/weston-vivante:2 container image on your device? The command should be something like:

docker pull torizon/weston-vivante:2

Run the command above on your device and see if it can get the container image.

Best regards,
Lucas Akira

Hi @lucas_a.tx,

Thank you very much. Looks like i had a connexion issue (no network) on the board.
Fixed it.

Now I have some kind of new issue when I try to run my app :
Failed to create wl_display (No such file or directory)
qt.qpa.plugin: Could not load the Qt platform plugin “wayland” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

This problem is appearing either when I try to debug from vscode or directly on the board (ssh) with the example tutorial (tuto) commands :

docker run -e ACCEPT_FSL_EULA=1 --rm -it --name=qt5
-v /tmp:/tmp
-v /dev/dri:/dev/dri -v /dev/galcore:/dev/galcore
–device-cgroup-rule=‘c 199:* rmw’ --device-cgroup-rule=‘c 226:* rmw’

/usr/lib/aarch64-linux-gnu/qt5/examples/quick/animation/animation &


Just for informative purposes, this last issue is currently being discussed here: