Problems with pulling Image from Local Registry on Host PC

I am having some trouble with pulling an Image from the local Docker Registry (on the Host pc) when called from the Toradex module. This only happens on my pc as my colleagues don’t experience this problem and use the same vs code project (we are using dev containers with the Torizon IDE extension and a .NET codebase).

Two weeks ago this was not giving any problems when I first tried it, but now something has changed and I can’t pull images from the registry anymore

The error is Error response from daemon: Get “”: net/http: request canceled (Client.Timeout exceeded while awaiting headers) and is returned when calling
LOCAL_REGISTRY= TAG=arm64 docker compose pull em-sdc-a53-debug

Our setup:

  • Custom carrier board with Verdin imx8m-mini (
  • Latest Torizon OS
  • Host PC with ip:
  • Docker on host pc with registry on port 5002 (generated by project in vs code)

What we already tried:

  • My colleagues can access the same Verdin module and pull an image from the registries on their respective pc’s
  • They can’t pull an image from the registry on my pc
  • I connected to my colleagues network switch to check if my switch was the problem => still didn’t work
  • Disabled firewall
  • Uninstalled Docker Desktop and reinstalled it
  • Removed registry and rebuilt it from vscode
  • Checked wireshark loggings to see whats happening (added the wireshark log below)

From the wireshark loggings it seems I get a lot of TCP errors and not all HTTP communication is present that I see when comparing with a wireshark logging of my colleagues when they pull the image from their pc’s.

test4.pcapng (50.9 KB)

Can someone help me with this problem? Because at the moment I am stuck with this problem as I can’t debug my code. I can provide more info if/when needed.

Hello @Jorn,

Can you give me some more details about your setup?

  • What OS are you using on your host PC?
  • What is the subnet mask of your network? You can check this with one of the following commands:
    • Windows: ifconfig
    • Linux: ip addr show, we are interested in the number after /, next to your ip address. For example: 24 in
  • Can you access the module with your PC via SSH?

What I think may be the problem is that the two devices are in different subnets: 10.101.10.* and 10.101.30.*.
If this is the case and the problem is persistent even after you connect to your colleagues’ network switch, it is possible that your PC has a static IP address configured.

Best Regards,

Hello Bruno,

We found a solution, but are still unsure why it happens. We had to change to port 5003 instead of 5002 and then everything works fine again. Not sure why this happened, we did see that microsoft’s svchost was also using this port. Maybe it has something to do with this. In the wireshark logs we see that most TCP packets are sent twice so this made us think that the port was being used twice.

Hello @Jorn,

The port 5002 being used is an unusual issue.
Thanks for sharing that this was the problem.

Best Regards,