Problem with winsock2 connect method

We like to update to the newest image version (V2.4) of Apalis T30 windows embedded compact 2013. Here we noticed an error at connect method of winsock2 api. It returns 10022, which is WSAEINVAL. Do you have any solution for me? On V2.4b2 same code is running.

Apalis T30 2GB V1.1b
Ixora V1.1A
WEC2013 V2.4

Dear support team,

We found the problem. We build an custom image with the newest workspace to implement a touch driver from manufacturer. The building of OS was successful but I think not good. When I use origin image from you, everything works fine. I read that you offers help creating CAB installers. I also think, that this would be the best way. I upload files I got in the past from manufacturer. Would you send me an offer on how we can solve this?

And here comes the driver.
EasyTouch (3.9 MB)

Yes we can create a CAB installer but its not covered by free support. You need to order 4 support hours. PN: 10000000

Dear @alex.tx
We ordered the support hours. You have confirmed the payment of invoice number CHTA-SI-009918. What are the next steps now?

Have you tried to manually install files from your zip to check if it works as expected?

  • Copy all DLL files from to \FlashDisk\System
  • Modify registry:



; how long touch proxy will wait for touch driver to load
    "DriverLoadTimeoutMs"=dword:1 USB connecting)


Hello @alex.tx
Yes we tried that allready in the past. We also tried to overwrite existing tchproxy.dll in System folder with Flashdisk/AutoCopy folder.