Problem with several USB-Storage

HI, we have a problem with several USB-Storage. Sometimes the U-Boot cannot access to our used USB Storage.

Sometimes in five of six times the USB Storage works fine. in other Cases the Same USB works in one of six times.
i did not remove the Stick from the USB Port during the Tests. i only rebooted the system by reseting the hardware.

The Terminal gives the error massage if we try to flash the Colbri-Module with our OS.
The os is a Yocto Angstrom distribution.

"epis iMX7 # run setupdate
** Unrecognized filesystem type **
starting USB…
scanning bus 0 for devices… EHCI timed out on TD - token=0x80008c80
unable to get device descriptor (error=-1)
2 USB Device(s) found
scanning bus 1 for devices… 2 USB Device(s) found
scanning usb for storage devices… 0 Storage Device(s) found
** Bad device usb 0 **
FEC0 Waiting for PHY auto negotiation to complete… TIMEOUT !
Could not initialize PHY FEC0
Using FEC0 device
TFTP from server; our IP address is
Filename ‘colibri_imx7/flash_eth.img’.
Load address: 0x80800000
Loading: *
ARP Retry count exceeded; starting again
epis iMX7 #
The routing of the USB is from colibri module to a USB hub SMSC2512 and from the Hub tu the USB A Ports.

Used USB is Intenso Alu Line 4GB FAT32.

Colibri IMX7D 512MB eMMC
Custom Carrier Board

Hello Stengel,

I encountered Problems like this one before and very often it signal integrity issues.
can you please provide your schematic for a review. your can send them to
please include a reference to this ticket in the email.


Just throwing this out here.

Are you using USB 2.x?

There is a rash of USB 2 stuff out there that only works some of the time. It’s lower-end/cheaper and I encounter it on eBay quite often. Some of the USB 2 drives I bought on there were so thin you could put them in upside down. I have bought thumb drives that would work in 3 out of 4 desktop computers on the project. Not “generic” desktop computers, mind you, HP and Lenovo. Adding insult to injury, it wasn’t always the same machine that was picky.

I’ve even had the USB 2 finicky problem with name brand media.

I do not encounter this problem with USB 3. Not to say it isn’t possible, just saying I’ve never encountered it. I think they tightened up the specifications, at least for sizes. I’ve encountered a few generic USB 3 devices that will not successfully fall back to USB 2 but I’ve never had the finicky port problem.

HI seasoned_geek,

the USB-Stick, who does not work very well on our custom carrier board, works all fine at an PC (HP Probook).
it seams to be that the fault is only in U-Boot mode at High speed funktionality. In kernel mode or on the OS the Stick works. But it seamst the speed is only Full Speed.

Best regards

Hello stengel,

like I said we like to take a look at the schematic.

Best Regards,


HI matthias,
i sent the gerber data to the support mail. with the reference to this thread

Best regards

hi can you provide me the ticket number? The I can find it faster.

the support did not respond on my mail till yet.
i sent the mail on wednesday the 15th of december.
it could be the mail was sorted out by the spam filter.

Best regards

Hello Stengel,

with file attachments it gets filtered out sometimes.
So like link we sent you to upload is the better way.
And this way we received your upload file which you uploaded to our server and will check it.

Best Regrads,



does the USB devices work with the kernel or do you see the same Problems using the kernel.

Best Regards,



The USB works fine in User Space with 12 Mbit/s.
this problem is only in u-Boot with 480MBit/s
i have also desoldered the inductions in the ground line of the USB-Devices. Now the current back path have low induction. the USB signal get a sharper edge but the problem is still available.

Best Regards

Hi @Stengel !

So, you need lower speed on Uboot (from 480Mbit/s to 12Mbit/s)?
From your first message, seems like the issue is that Uboot isn’t able to recognize the USB stick, right?

Have you tried the same process on a Toradex Carrierboard (Iris, Viola or Evaluation Board)? Did you get the same issue?

Best regards,

HI i checked it on the Col Evaluation v3.2B and i got the same issue.
The amount of the tries with the evaluation board got a better result. I got the issue in one of six tries.

i used the custom Linux from our compüany and the Toradex Embedded Linux 5.5.0 + build 15 out of the Easy installer.

Best Regards


we tested on our side and it worked. we used the downstream image. Can you please try with a different USB stick.