Problem with downloading kernel in yocto


I did an update of the diverse toradex GIT repository to upgrade from 5.7.4 to 5.7.6, but when I started to generate the image, yocto could not download the kernel from Toradex gitt repository.

WARNING: linux-toradex-5.4.193+gitAUTOINC+eb8d1c92da-r0 do_fetch: Failed to fetch URL git://;protocol=https;branch=toradex_5.4-2.3.x-imx;name=machine, attempting MIRRORS if available
ERROR: linux-toradex-5.4.193+gitAUTOINC+eb8d1c92da-r0 do_fetch: Fetcher failure: Fetch command export PSEUDO_DISABLED=1; export DBUS_SESSION_BUS_ADDRESS="unix:path=/run/user/1000/bus"; export SSH_AUTH_SOCK="/run/user/1000/keyring/ssh"; export PATH="/home/adrian/oe-core/build/tmp/sysroots-uninative/x86_64-linux/usr/bin:/home/adrian/oe-core/layers/openembedded-core/scripts:/home/adrian/oe-core/build/tmp/work/verdin_imx8mp-tdx-linux/linux-toradex/5.4.193+gitAUTOINC+eb8d1c92da-r0/recipe-sysroot-native/usr/bin/aarch64-tdx-linux:/home/adrian/oe-core/build/tmp/work/verdin_imx8mp-tdx-linux/linux-toradex/5.4.193+gitAUTOINC+eb8d1c92da-r0/recipe-sysroot/usr/bin/crossscripts:/home/adrian/oe-core/build/tmp/work/verdin_imx8mp-tdx-linux/linux-toradex/5.4.193+gitAUTOINC+eb8d1c92da-r0/recipe-sysroot-native/usr/sbin:/home/adrian/oe-core/build/tmp/work/verdin_imx8mp-tdx-linux/linux-toradex/5.4.193+gitAUTOINC+eb8d1c92da-r0/recipe-sysroot-native/usr/bin:/home/adrian/oe-core/build/tmp/work/verdin_imx8mp-tdx-linux/linux-toradex/5.4.193+gitAUTOINC+eb8d1c92da-r0/recipe-sysroot-native/sbin:/home/adrian/oe-core/build/tmp/work/verdin_imx8mp-tdx-linux/linux-toradex/5.4.193+gitAUTOINC+eb8d1c92da-r0/recipe-sysroot-native/bin:/home/adrian/oe-core/layers/openembedded-core/bitbake/bin:/home/adrian/oe-core/build/tmp/hosttools"; export HOME="/home/adrian"; LANG=C git -c core.fsyncobjectfiles=0 fetch -f --progress refs/heads/*:refs/heads/* refs/tags/*:refs/tags/* failed with exit code 128, no output
ERROR: linux-toradex-5.4.193+gitAUTOINC+eb8d1c92da-r0 do_fetch: Bitbake Fetcher Error: FetchError('Unable to fetch URL from any source.', 'git://;protocol=https;branch=toradex_5.4-2.3.x-imx;name=machine')
ERROR: Logfile of failure stored in: /home/adrian/oe-core/build/tmp/work/verdin_imx8mp-tdx-linux/linux-toradex/5.4.193+gitAUTOINC+eb8d1c92da-r0/temp/log.do_fetch.740058
ERROR: Task (/home/adrian/oe-core/build/../layers/meta-toradex-nxp/recipes-kernel/linux/ failed with exit code '1'
  1. Can you check that is working correctly
  2. I thought you upgraded the kernel version in 5.7.6, why is it still downloading 5.4.193 ?


A workaround was made by reverting meta-toradex-nxp.git - Toradex BSP layer, recipes for NXP based modules

Hello @luciolis, is working as expected.
The issue you encounter can happen sometimes.
The kernel repository is really big and the download can take a long time

I would recommend that you retry the download. This can be done by running:

bitbake linux-toradex -c do_fetch

I thought you upgraded the kernel version in 5.7.6, why is it still downloading 5.4.193 ?

For the same major version of a BSP, in this case BSP 5, we do not change the kernel version, but only add security patches and fixes to it.
This is done to ensure an easy upgrade path for users of the same major BSP version while keeping the kernel up-to-date and secure.

If you are looking for a newer kernel version, a downstream NXP-based kernel 5.15 is available on the Toradex BSP 6 for i.MX8 modules.

For more details on our Linux Support and software versions, please have a look at the following resources:

Best Regards,

I was mentionning that but now I see it’s only for the upstream kernel.

I have tried to port our software into BSP 6, but it was too complicated to port all our kernel patches to the newer version, and we are now way past the development stage of our product.

I do not think the do_fetch will work, because I have deleted all build temp folders and it was still giving the error.

Hi @luciolis,

I do not think the do_fetch will work, because I have deleted all build temp folders and it was still giving the error.

You can try removing the downloads folder, on the same level as the layers folder before trying again.

I tested the kernel download using Yocto earlier today and it worked without issues.

Best regards,
Bruno Mello

Thanks, I will try this.